PXE-55 and "Message Type Not Handled By CloneDeploy Proxy DHCP - Ignoring Request"



  • How\What do I need to verify to see that it was done properly?



  • Should look like this.
    [code]ls -lh
    total 0
    lrwxrwxrwx 1 root root 12 Mar 9 14:54 images -> ../../images[/code]

    [code]ls -lh /tftpboot/proxy/bios/images/
    total 30M
    drwxr-xr-x 2 root root 4.0K Oct 7 2013 init
    -rwxrwxrwx 1 root root 30M Feb 6 2014 initrd.xz[/code]

    Delete the images and kernels folder from each proxy/bios proxy/efi32 and proxy/efi64 folder and run the symlink commands again



  • What is your cwd when you type the first "ls -lh"?



  • [code]/tftpboot/proxy/bios/[/code]



  • I deleted the symlinks and got this before running the symlink commands:
    [code]root@ubuntu:/tftpboot/proxy/bios# ls -lh
    total 860K
    -rwxr-xr-x 1 www-data www-data 2.0K Mar 7 13:19 bg.png
    -rw-r--r-- 1 www-data www-data 120K Mar 7 13:19 ldlinux.c32
    -rw-r--r-- 1 www-data www-data 183K Mar 7 13:19 libcom32.c32
    -rw-r--r-- 1 www-data www-data 24K Mar 7 13:19 libutil.c32
    -rwxr-xr-x 1 www-data www-data 90K Mar 7 13:19 lpxelinux.0
    -rw-r--r-- 1 www-data www-data 46K Mar 7 13:19 pxeboot.0
    -rw-r--r-- 1 www-data www-data 46K Mar 7 13:19 pxelinux.0
    drwxr-xr-x 2 www-data www-data 4.0K Mar 9 14:15 pxelinux.cfg
    -rw-r--r-- 1 www-data www-data 307K Mar 7 13:19 undionly.kpxe
    -rw-r--r-- 1 www-data www-data 27K Mar 7 13:19 vesamenu.c32[/code]
    Should I delete the contents of this directory (and other 5 as well)?



  • no, keep everything else



  • Ok, that worked! Thanks so much.
    May I suggest the installation manual be updated? It looks like 6 "cd /tftpboot/{bios,efi32,efi64}" commands are missing before each "ln -s" command.



  • It doesn't matter where you run the command from. It's relative to the destination not your current directory.



  • Ohhh I see. Sorry for the confusion and many thanks for the help. I really appreciate the responsiveness.



  • Guest said in PXE-55 and "Message Type Not Handled By CloneDeploy Proxy DHCP - Ignoring Request":

    It doesn't matter where you run the command from. It's relative to the destination not your current directory.

    Replying to a 1,207 day old post to say thank you. Glad this was on here, my setup is working great, I just couldn't handle not knowing the symlink target with ../../ is relative to the destination 👊 You saved my life of worry and ocd!