Could not contact CloneDeploy server



  • I'm pretty new to CloneDeploy, but have had great success until recently. I have an HP Probook 650 G1 - when I try to add a computer in order to capture the image that I've prepared on the laptop:

    Could not contact clonedeploy server. Possible reasons: web service not functioning / a driver could not be found for this nic / did not receive an IP address.

    I searched your forms and the only thing I could come up with was a kernel update, so now I'm booting to cd with 4.10.1x64 kernel. symptom didn't change. could you please help? what am I missing?? thanks!



  • If dhcp fails you should get a menu option. If you select display available nics, is anything listed?



  • yes, the loopback and

    eth0 : encap: Ethernet, mac address,
    UP BROADCAST RUNNING MULTICAST MTU:1500
    rx packets:71008 dropped:525 (all else:0)
    tx packets:3 all:0

    happy to provide more detail if you need 🙂



  • Does the mac that is displayed match the internal nic? Also, are you certain the correct kernel is being loaded?



  • Yes, MAC is correct. and when I boot to the cd - and then from the boot menu - select Add Computer - the first lines of feedback look like:
    loading /clonedeploy/4.10.1x64.... ok
    loading /cloandeploy/initrd.xz...



  • Could you try assigning a static ip to rule out a dhcp issue? It should be an option in that menu after it fails. Then we can move on to diagnosing the driver issue if that doesn't work.



  • Assigned static ip - got the following in return:
    ifdown interface eth0 not configured
    and then back to the could not contact clonedeploy server... message.



  • We need to get that machine into the client console.

    Build a new usb/iso but for the boot image drop down, select debug
    Boot that machine and select any menu option
    You should now be at a shell
    enter [code]lspci -nn[/code]

    Post a pic of the output



  • Attached - 🙂



  • Seems like that nic has had support in the kernel for a long time now, so it should work.
    How about these commands. I'm only interested in the dmesg output.
    [code]ip link set eth0 up
    udhcpc -i eth0
    dmesg | grep e1000e[/code]



  • Attached -



  • From everything you have shown me I can't see any reason why It shouldn't be working. Do you have any other of this machine. Have you tried other one's, different switch, cables, etc? It seems to me the hardware is working but just isn't getting an address for some reason.



  • Also which kernels have you tried? Have you tried any of the older ones?



  • Started off with 4.5 - then from there jumped to 4.10.1

    I have a few other Probook 650 - will pull and try.

    as far a switch / cables /etc - it's the same hdwr that I use for countless other 'things' that I do with many different pc's / devices - like a lab environment. So the hdwr is known to be good...

    anyway, I'll try with another box and will update.

    you've been extremely patient and helpful - very much appreciated!



  • I really hope I haven't wasted your time... but here's the update - I pulled another brand new probook650 OOB and it connected fine. I used same switch / port / cable / everything. I then plugged in the trouble box - same platform / switch / port etc etc. - and it worked. And trust me that over the last several days I've reseated all cables in question several times...

    again, sorry to have wasted your time. but I'm very thankful for all your help.

    I wonder if I have a flappy port on the switch or an 'iffy' cable / connector??

    anyway thank you so much 🙂