Error copying files

  • This just started today after several successful uses on the exact same machine type. I'll start a task and deploy an image, and once it gets about half way through the file copy on the main partition it'll error out with "No space left on device". I've already wiped the drive beforehand and destroyed the GPT/MBR. Has anyone else had this issue? There is more than enough room on the partition it's copying to, it almost seems like it's not expanding the image before files are moved.

  • Yes, it looks like the partition is not expanding. The strange thing is that it doesn't look like it's even trying to. On that machine that failed to expand can you boot to the client console and run
    [code]parted -s /dev/sda unit b print all[/code]

    Post the results

  • This is what I got.

  • That looks normal and this doesn't make sense. Nothing has changed? Have you updated CloneDeploy recently?

  • I have not changed anything recently, I'm running 1.2.1. What's even stranger is the same time I deployed this machine I deployed another that was a different type running an nvme drive and it worked fine. Same image, different profile. I have since tried to redeploy this machine, but got the same thing.

  • Have you made any custom changes to the core scripts? If not I'm going to add a few changes to get a couple values to see where it's going wrong, then you can just overwrite the file.

  • I have not. A previous incarnation of the clonedeploy server had some changes, but I have since rolled back to a previous checkpoint and everything should be fresh. I just deleted the computer, group, and profile and rebuilt them but to no avail.

  • Overwrite this cd_push file in your web directory\private\clientscripts

    Run the deploy again and attach the log

  • Not gonna bother redacting this one

  • I took it down for you. I see the issue.
    partition_size_bytes hynix

    Should be a number but for some reason it's matching something with the hard drive model.

  • Oh yeah, I see that now. Why would it do that for just partition 2 though? For partition 1 and 3 it's reading the correct byte size.

  • Give this a shot. In the parted output I'm searching for a partition number, in this case it's space 2 space. Which also happens to match the end of your model line
    Model: ATA SK hynix SH920 2 (scsi)

  • Looks like that did it! Coincidental that the SSD in my machine had the exact phrase you were parsing for. Since we get different machines with different models, will this change how they are imaged or break things if a different SSD model is used?

  • No, nothing was done for specific to that model. I just tried to make the search more specific so to not match model info. We'll need to wait and see how it goes.

  • Alright, I don't have any machines to deploy right now, but when the next batch comes in I'll give a quick update. Thank you for your help.

  • I just deployed another machine that had a Toshiba type SSD and completely different ending on the model number, and all appears well. I'll continue to keep an eye on it, but it looks like it's been solved.