WinPE Deploy issue, and odd partitioning

  • I'm having an issue using the win-pe pxe boot method for deploying an image
    Creating the image seems to work fine, but when I go to push it to a system it just deletes the partitions, and gives me a bunch of errors then reboots
    I'm on 2.0.1 and have used the latest PE builder

    I've attached a log of one of the attempted deployments

  • I was able to get this one working based off a patch found in another post
    However I'm having a weird issue with all my images.

    When I deploy to a Surfacebook via WinPE I'm getting a 2.61 unallocated partition
    When I deploy to a Mac using the NBI I get a weird 2.74 "Free Space" Partition

    I'm using block level captures, and those partitions don't exist on the originals...any idea why that's happening?

  • Do you have the link for that post? I was looking for it to point you there but apparently I can't search my own forums. As for your issue, it really depends on how your original partitions were setup. CloneDeploy has the ability to resize all partitions in order to make them fit. It usually saves some space to account for math errors. This empty space isn't always there but it can happen.

  • Link:

    Partitions for windows are System/Reserved/OS/Recovery

    Would moving Recovery to be behind the OS allow CD to expand the OS partition for me?

    I think OSX is similar, OS-Partion/Recovery

    In both cases the free/unallocated space ends up behind the recovery partition

  • Yes, the recovery being at the end is causing the issue. It would need to come before the OS, then the OS would expand to fill the rest of the drive.

  • Partitioning still isn't working as I'd expect it to (not sure if this is just how it works)
    OS Partition is at the end now but it still doesn't extend
    Tried the normal linux based booter for a dell as well, and ran into a similar problem
    The image I took was from a drive half the size, when deployed the main partition isn't extended and I have over 100GB unallocated

  • That definitely shouldn't be happening. Can you attach one of those deploy logs?

  • Attached for both Surfacebook (WinPE EFIx64...2.6GB unallocated) and Dell (Legacy, linux 119GB unallocated)

  • For the linux environment. You have something slightly unusual going on. If the hard drive is an exact match as the original image, then partitions are not adjusted. Your hard drive is 200+ GB but for some reason your original partitions were only around 100GB. Since the drive is an exact match CloneDeploy just lays down the exact same partition table. Anyway, in your image profile deploy options just enable
    Force Dynamic Partition For Exact Hdd Match
    and that should take care of it.

    Now the WinPE environment looks like I didn't code it properly. I'm not expanding the final partition to fill the rest of the drive. I'll need to add this to my list for 1.3.0. The WinPE environment is still in early stage of development, I think only a handful of people have even tried it, most use Linux.

  • An option for the winpe environment is to select standard for the create partitions method. I think that should fill the disk.