MBR Breaks when Computer Imaged

  • Hello,

    I've run into a funny issue. I'm running ubuntu 16.04 LTS and have uploaded several images to the server which goes smoothly. I have then deployed these images and usually the first two computers works perfectly well. The third computer is usually when I run into an issue. The MBR will break. It will look like it's booting into windows and then freeze, try to run a start up repair, and then fail.

    What I've tried:
    Start up repair from a windows 7 disk
    All of the bootrec commands
    re-imaging the computer from a blank HD

    I will continually get this on every computer after for every image. Does this make sense to anyone?

  • Are they all the same model? Image taken from that model? Did you check the hard drive mode in the bios? ie: ide,ahci,raid

  • They are all the same model and hardware configuration. I'll make an image for each one. The current batch of computers I'm having trouble with are all Dell Optiplex 3020. The hard drive mode in the bios is set for AHCI. You do have to do some configuration in the bios prior so the computer can PXE boot.

    Legacy mode has to be enabled to be able to choose "boot from lan"
    PXE boot has to be enabled
    Secure boot has to be disabled.

  • Are you sure the uploaded image was also set to ahci. Other than that I would need to see the upload and deploy log