WinPE \Boot\BCD missing

  • I've followed the guide for the WinPE images, created an image in Windows, transferred it to my CD-Linux and ensured that all permissions are correct.

    Now, if I try to boot with the WinPE Efi-x64 setting, I get an error screen telling me:
    File: \Boot\BCD
    Status: 0xc000000f
    Info: The Boot Configuration Data for your PC is missing or contains errors.

    The file definitely exists in \tftpboot and is accessible to all users.

    CloneDeploy version is 1.2.1

    Any help is appreciated! 🙂

  • Could case sensitivity be an issue? Are you using proxy or non proxy.

  • non proxy

    All settings and configs are untouched and I followed this guide exactly:

  • Does anything change if you change the boot folder to Boot?

  • I copied boot to Boot, nothing changed. Is there any log from Clonedeploy?

    oh btw, ipxe_efi64 worked fine all the time. I just need WinPE for my Surface Pro to deploy an image.

  • No, CloneDeploy isn't really involved at that point, it's only the tftp server. I'm wondering if something is slightly different since your using a tftp server on Linux. I honestly haven't tried WinPE when CloneDeploy is installed on Linux.

  • Oh ok.. well, we tried it with a Windows server at first and had a lot of trouble. On Linux, everything has been running perfectly fine for the last 8 months. Almost zero maintenance, I only updated the kernel from time to time. So I thought Linux was the main platform for Clonedeploy 😄

    Maybe I'll just have to install the Surface manually then if there is no other way at the moment 😕

  • What issues are you having with the surface? Which model?

  • Surface Pro 4. It's not getting an IP when booting in ipxe_efi64. All other devices (and we have plenty of different models and brands here) boot perfectly fine.

  • I suppose, the network adapter is not fully supported by the current kernel (4.10.1x64)

  • Are you using the surface usb to ethernet adapter. That's why I use and don't have an issue.

  • We don't have the official Surface ethernet adapter. I'm using one of the Surface docks instead.

    All other laptops work with an USB3 ethernet adapter, but the Surface only accepts the original accessories.

  • Ic. Yes, the docks are usually an issue. Might be a long shot but what if you plug the usb adapter into the dock.

  • Already tried that 😄 I plugged in the dock and the additional usb adapter. Had a similar problem with a Dell Optiplex and that solution worked fine. But not this time. That's why I really dislike the Surface line from an Admins point of view 😕

  • I guess I solved the Surface problem! Had to wait for a long time, then Clonedeploy offered me a manual configuration of the ethernet adapter. I've put in the details and now it's running as usual 🙂