Surface Book no ethernet driver

  • Hi again,

    I got the original Surface USB Ethernet Adapter today and tried to deploy an image to my Surface book again.

    Same story as last time: Kernel 4.10.1x64 doesn't find a driver for the network card. Older kernels just wait for an eternity to obtain an IP, but finally fail, too. Any advise?

  • Seems strange. I typically use the 4.5 kernel with the surface, but have not had issues with it getting an address. You could try setting the ip ahead of time. Make a new image profile called surface or whatever and for the pxe boot options->kernel arguments, pass in the following

  • The error occurs before selecting an image:

    • I select PXE boot in the Bios options
    • iPXE initialising devices...
    • Menu
    • I select "On demand"
    • Kernel is loaded
    • udhcpc started. Sending discover...

    The surface is not getting an IP at this point, manual IP selection is not possible. So I suppose it doesn't even recognize an ethernet adapter.

  • I solved the problem!

    The Surface Book has problems with the base unit when booting into CloneDeploy. Neither the keyboard nor the USB ports are usable at that time.

    I removed the base unit and attached the docking station directly to the Surface tablet. Then I booted until no ethernet driver was found (again). I plugged in another USB ethernet adapter from Anker (Amazon brand) and manually assigned the network settings. Everything booted fine afterwards 🙂