Only loopback Nic is available

  • I've scoured the net looking for an answer to this but just can't seem to find one.

    I've been using CD for a bit now and love it, however, I just got 5 new laptops in from Dell with Ubuntu installed on them. To cut the cost of the OS, I had Ubuntu put on them since we just reinstall the OS anyways.

    When I try to boot to CD, either with USB or PXEBOOT, I get as far as it saying it can't reach the destination IP address. Normally, this is fine, but in with these laptops, I can only add a static IP to the loopback nic card. When looking under available nic cards, only the loopback card is listed.

    I've done everything I can think of to get it to recognize the nic card. On the laptop side, it looks like Dell programmed them with Predictable Network Interface Names so the card reads out as enp0s31f. One the original Ubuntu 16.04 OS I removed the Network Manager completely and tried to change the name to no avail.

    Then I install Ubuntu Server 16.04 on it and was able to successfully editing the /etc/default/grub file to change the name and now my nic registers as eth0 but still CD does not see it. I'll keep looking but if anyone has any ideas, I'd be much appreciated.

    Thank you!

  • Have you tried the newest kernel

  • I've tried 4.5 and 4.5x64 (assuming those are those newest ones)

  • Boom! 4.7x64 worked!

    Placing it inside C:\Program Files (x86)\clonedeploy\tftpboot\kernels
    Then reloading CD interface, selecting new kernel, creating a boot menu and alas. Problem solved.

    Thank you again.