UEFI w/ SecureBoot?

  • Hi All,

    I've inherited a CloneDeploy setup and it seems like a great product. Unfortunately, the person that set this up previously didn't leave any documentation and didn't have it setup for UEFI imaging. Anyways, I'm having a rough time getting this working for UEFI images. Can anyone point me in the right direction?

    I've looked through the forums and came across this post:

    https://forum.clonedeploy.org/400-uefi-pxebooting/0 (we're using Windows DHCP as well)

    Unfortunately, still no luck.

    Thanks in advance for your assistance!

  • What's the specific problem? Is there an error message?

    your dhcp option should always be pxeboot.0 then you change your pxe mode to one of the efi options, such as ipxe or grub.

    Secure boot is tricky. Grub is the only option that might work. Otherwise you need to use the WinPE imaging environment for secure boot.

  • Thanks for the quick response! I tried using Grub and was getting a lot further than before.

    I was able to get to the menu and select Add Computer, then it prompted for a username and pass which
    I thought would be the CD credentials but those did not work and it rebooted after the second failed attempt.

    I then went into settings and disabled the password prompt for add computer and also checked off Force SSL.

    Unfortunately that seems to have blown it up and now nothing is working lol. Happy Friday!

    Is this recoverable or will I be reinstalling?

  • You can't force ssl until the cert is setup. You'll need to either setup SSL for the site or disable the setting in the database. You can use heidisql to manually change the setting back. It was installed with CloneDeploy.

  • Thanks for the quick response again! Unfortunately as I said above, this was an inherited setup and the previous admin didn't document anything so I don't have the DB credentials. I will need to reinstall.
    Is the uninstall process simple? Do you recommend installing the new beta version or something stable?

  • database credentials are in web.config

  • Awesome, was able to recover but still no dice using grub as an option with SecureBoot enabled. Looks like I'll be going the WinPE route. Thank you for all your help!

  • Have you tried an updated kernel? What kernel are you using?