Error booting after clone

  • Just got CloneDeploy setup and I'm having trouble getting my first clone done.

    Here's my scenario -

    • I have a reference image build on a VMWare Workstation Pro (CentOS7 with security configurations and corporate software)
    • I'm trying to deploy it to a Dell Precision Tower (T3610).
    • It seems to partition the disk and copy the hard drive image down correct
    • System fails to boot with any of the kernels I included
    • I get a whole bunch of this error "dracut-initqueue[347]: warning: dracut-initqueue timeout - starting timeout scripts"
    • followed by "A start job is running for dev-mapp...oot.device (13minute / No Limit)
    • Can't see the whole error, I assume it's dev-mapper.something.root.device, but it never goes away, it will sit there for days.

    I don't think this is related to CloneDeploy specifically, more likely it's my reference image, but I'm hoping theres some expertise there that can help. This is becoming urgent for my job, so I hope someone can help!


  • I would start by posting your upload and deploy logs, just to verify everything did work correctly on the CloneDeploy side.

  • Okay - thanks. I will work on that now - I've redone a lot of steps and have not really gotten it working yet. I was able to use clonezilla to get the VM from my VMWARE Workstation to a physical harddrive, and booted up in a laptop that I have. I wanted to eliminate VMWARE as a problem, so I am now cloning the physical HDD and attempting to deploy to another physical HDD.

    here's my newest upload logs.

  • Upload log looks normal. Post a deploy log when you get one.

  • Okay, I got pulled away from this project but I am back on task. I essentially started over from scratch, including updating my server to 1.3 (looks great by the way).

    OnDemand Upload seems to work fine.
    OnDepand Deploy seems to work fine.

    I get this when booting for the first time.

    "Dracut-initqueue[276]: Warning: Could not boot."
    "Dracut-initqueue[276]: Warning: /dev/cl_lx-centosref/root does not exist"
    "Dracut-initqueue[276]: Warning: /dev/cl_lx-centosref/swap does not exist"
    "Dracut-initqueue[276]: Warning: /dev/mapper/cl_lx--centosref-root does not exist"
    "Starting Dracut emergency shell..."
    "Warning: /dev/cl_lx-centosref/root does not exist"
    "Warning: /dev/cl_lx-centosref/swap does not exist"

    So, I boot into the rescue kernel... works just fine.

    I run the following command...
    "dracut --force --regenerate-all"

    Reboot again - everything seems fine.

    Any tips on avoiding this problem?

  • I need the upload and deploy log to try and see what's happening

  • Sorry, I meant to attach both. Here they are. I was using OnDemand deployments which worked really well it seemed.

  • Can't see anything wrong going on here.
    Can you attach /etc/grub2.cfg and /etc/fstab? from the original image, not a repaired one

  • I tried to replicate your problem but could not. I installed a copy of CentOS 7 with LVM setup exactly like yours. After deploying to multiple different machines with varying sized hard drives, they all booted successfully. Right now I'm not sure what's different about your setup.

  • Thanks for trying to replicate. I wonder if it has something to do with security features I have enabled or configured?

    Requested files attached (from the reference image)

  • Just following up. We are working around the issue for now, but I'd love to eliminate that step! Thanks.

  • Sorry, I have not found a solution to this. I still cannot replicate it which makes it hard to fix. Are you still creating the image from a VM or a physical machine?

  • I am creating the image on VMWare Workstation 12 Pro. I've seen the issue happen on VMWare Workstation, VMWare vSphere, Hyper-V, and on physical hardware (but not always). The last deploy I tested came down on my VMWare Workstation with no errors - booted right up beautifully.

    I realize this doesn't give you much to go on. Are there any logs from a client that failed to boot initially that might be valuable?

  • Hi, We had a very similar problem with Centos7.
    3 partitions:
    -1 swap standard
    -1 home LVM xfs
    -1 / LVM xfs

    We tried to upload it several times (even changing FS in ext4) but nothing worked.
    The best result we had :
    Seems to start but finished with an error message abut Dracut.
    The worst result : Image refuse to deploy.

    I'll try to upload my logs this week.

  • Here are the two logs. The deploy seems to have error related to EBR but honestly I don't know why and what to do.

    Many thanks by advance for your help.

  • It looks like there may be a logic error in the math of creating the lvm. It's difficult to say though since your upload log and deploy are actually two different images. Do you have matching logs?

  • Sorry. Here are 2 fresh logs.
    One from source computer, other from Destination. Same image.

  • Thanks, it's definitely a calculation issue, as seen here.
    Volume group "centos" has insufficient free space (85067 extents): 85068 required.

    For some reason I am one off. But I'm not sure why at the moment because it seems to work for me, but I am testing with much smaller drives. Are you deploying to smaller drives with this image, if not, you may be able to use the "don't shrink lvm" option to overcome this.

  • Hi,

    Disable shrink did not helped. But My colleague build the PC source using CentOS self-partitionning then modify it. And the issue was there.
    I rebuild the Centos by myself, did the partitioning by myself too.... And everything is OK!

    I don't know if the problem comes from the way the partitioning is done by the installation CD or because my colleague let the installation process do it and then modify it, but CloneDeploy is not part of the problem. Good news!!

  • That's good, still seems strange though.