Network Card Driver (NIC)

  • Im trying to upload an image using Clone Deploy, everything looks good, BUT.. on the Upload PC, Clone Deploy does not provide a Universal driver to my Intel Nic,, I have tried the Static IP route, they are on the same scope, everything looks good but no NIC.. so no upload,, I am using version 1.02..and a USB boot stick,, I will need instructions on "how" to add a different Kernel, or add a NIC driver to the boot stick..
    Really need this to work,, just a few pointers would be greatly appreciated!!

  • Is this a new installation. If so I would recommend upgrading to 1.3.0 as it has much newer kernels

  • yes New Install.. so may I upgrade within Clonedeploy?
    thanks 🙂

  • No, the upgrade is a manual process. It's outlined in the documentation. You can try the upgrade if you want. If it were me and since it's a new install. I would just start over. Clean OS install, clean CloneDeploy 1.3.0 install.

  • On it.. BUT.. cannot clean the OS.. it is a server.. with other stuff on it.. 😞
    will try and clean out what I can.. keep my fingies crossed!~
    Thanks will update

  • You must use upgrade then. Don't attempt to install new copy of 1.3.0 on a machine that once had a previous version.

  • Ahhh.. ok.. thank you greatly appreciated.. so when I run the installer,, there is an upgrade option on the main screen,,
    will choose that..
    update soon,,

  • Ok,, so all seems to have gone well with the upgrade.. I think,, Im at line 28 of the upgrade trying to log back into the app.. but get an error on my password with "Could not contact token API"
    tried my password and default.. same answer

  • The api is not setup correctly. Verify the IIS config for the API is correct and you updated the password correctly in web.config

  • ahh.. yes.. I did put a password in there,, but the one from the .bak folder .. is it best to redo the upgrade process from the command prompt? or manually edit the "applicationhost.config" file? .. The passwords that I retreived were the database password and the encryption key password,, but neither reflected my logon password..
    thanks for the pointers and help!

  • ok.. so in the API.. test connections.. the Authorization states that it cannot verify access to Path " C:\Program Files (x86)\clonedeploy\application"
    where does it access this authentication..
    I have looked at Web.config. and neither the password for the db nor the encryption reflect my logon password..
    What am I missing?
    sorry,, thanks

  • The password should be your database password from the old web.config, not your login pass. It sounds like iis may not have permissions to read that folder.

    Did these command run successfully?

    [code]icacls "C:\Program Files (x86)\clonedeploy\application" /T /C /grant IIS_IUSRS:(OI)(CI)M

    icacls "C:\Program Files (x86)\clonedeploy\frontend" /T /C /grant IIS_IUSRS:(OI)(CI)M[/code]

  • thanks.. Im getting this,, ok,, so.. my login password was not from line 8 or line 122.. as per the instructions,, so I did not think that it would be affected,, but an now seeing it may have been?.. I did put the proper passwords in as per your instructions and have tried them,, but I found the message in the Test connections with the api..
    I ran the icacls files and they passed through their process and I assumed they were successful..
    I am with you on the permissions,, may I rerun those commands and see if it affects the outcome?
    I have removed the api, and am re-inserting it,, hope that doesnt hurt..
    thanks for your patience,, im just learning this stuff..
    will update.

  • Hola!
    Yes,, ran those commands and were successful for 379 with 0 fails
    second command line 833 success 0 fails
    still unable to login to dashboard ( could not contact token API)

    However, if I go into api, and choose "connect as".. and I put in the admin user/password.,I get a connection..
    BUT.. when I try to logon, fail with same message..

    HELP 🙂

  • That error can be ignored, its normal. Can you post a screenshot of your iis manager with clonedeploy expanded.

  • certainly
    Here it is,

  • What do you get from this address, run on the server

  • Connection Refused
    Description: connection refused

    thats it.. 😞

  • this is some extra info which may help.. I am on server 2008 r2
    have mozilla as my default..
    BUT.. opened in IE and got this detailed error..
    the file "token".. does not exist in the physical path.. in windows explorer when I follow the path there is no file "token"..

  • Morning,
    Would you happen to have any recommendations for this ,, sorry, not certain how to create what is needed and unable to login..
    I would really like this to work and am hopeful..