Imaging Environment Issue



  • Hello,

    We have recently upgraded to CloneDeploy 1.3.0 an we are having issues deploying existing images...

    We are getting the following error message on the clients we are trying to deploy to:

    "** An Error Has Occurred **

    ...... The Imaging Environment For The Image Does Not Match The Currently Loaded Environment"

    Any ideas?

    Cheers
    Chris



  • I'm guessing it's the linux imaging environment and the image is set to linux?

    What if you just update the image in the WebUI?



  • Yes, that seems to be the case.

    I've tried updating the image in the WebUI but I still get the same error.

    Please see attached for the current settings, the "Client Imaging Environment" dropdown does not do anything.



  • Can you dump the images table for me and attach it here?
    [code]
    cd "c:\Program Files (x86)\MariaDB 10.1"\bin[/code]
    [code]mysqldump.exe --user=root --password clonedeploy images > %userprofile%\desktop\images.sql[/code]



  • Sure, please see attached.



  • This should take care of it. Thanks for the info. It looks like your machine has been upgraded multiple times, something I overlooked.

    [code]mysql.exe --user=root --password clonedeploy --execute="update images set image_environment = 'linux' where image_environment='';update images set image_environment = 'linux' where image_environment is null;"[/code]



  • I'll add to upgrade documentation



  • Excellent, that seems to have fixed it.

    Thanks for the prompt response!