Upgrade from 1.2.0 to 1.3.0, no mapping between...



  • Hey,

    I just tried to upgrade clonedeploy from 1.2.0 to 1.3.0. Eveything went fine until i came to point 19 and 20 from the upgrade documentation, there i get this message :
    "IIS_IUSERS: No mapping between account names and security IDs was done.
    Successfully processed 0 files; Failed processing 1 files"

    Can anyone help me with this problem?
    Thank you.



  • You have it spelled wrong. Should be IIS_IUSRS



  • First, thank you for the fast reply. I corrected the typo and the two steps finished without a problem.

    Unfortunately, now when i try to log in iget this error at the login page :

    "Unknown Error With Token API" and i stay at the login page...

    Can you also help me with this problem please?



  • Most likely a database password problem. Did you update the web.config to the correct password?
    You can check the logs at application\private\logs and frontend\private\logs for any clues



  • The web.config was updated correctly as in the documentation.

    The log file from the application is empty.

    The log file for the frontend throws this error :

    2017-10-10 07:16:22,008 [7] ERROR CloneDeploy_ApiCalls.TokenApi Error With Token API: System.Xml.XmlException: '100' is an unexpected token. The expected token is '"' or '''. Line 28, position 80.
    at System.Xml.XmlTextReaderImpl.Throw(Exception e)
    at System.Xml.XmlTextReaderImpl.ParseAttributes()
    at System.Xml.XmlTextReaderImpl.ParseElement()
    at System.Xml.XmlTextReaderImpl.ParseElementContent()
    at System.Xml.Linq.XContainer.ReadContentFrom(XmlReader r)
    at System.Xml.Linq.XContainer.ReadContentFrom(XmlReader r, LoadOptions o)
    at System.Xml.Linq.XDocument.Load(XmlReader reader, LoadOptions options)
    at System.Xml.Linq.XDocument.Parse(String text, LoadOptions options)
    at RestSharp.Deserializers.XmlDeserializer.Deserialize[T](IRestResponse response)
    at RestSharp.RestClient.Deserialize[T](IRestRequest request, IRestResponse raw)
    2017-10-10 07:16:22,023 [7] ERROR CloneDeploy_ApiCalls.TokenApi Error With Token API: <!DOCTYPE html>
    <html>
    <head>
    <title>Object reference not set to an instance of an object.</title>
    <meta name="viewport" content="width=device-width" />
    <style>
    body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
    p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
    b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
    H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
    H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
    pre {font-family:"Consolas","Lucida Console",Monospace;font-size:11pt;margin:0;padding:0.5em;line-height:14pt}
    .marker {font-weight: bold; color: black;text-decoration: none;}
    .version {color: gray;}
    .error {margin-bottom: 10px;}
    .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
    @media screen and (max-width: 639px) {
    pre { width: 440px; overflow: auto; white-space: pre-wrap; word-wrap: break-word; }
    }
    @media screen and (max-width: 479px) {
    pre { width: 280px; }
    }
    </style>
    </head>

    <body bgcolor="white">
    
            <span><H1>Server Error in '/clonedeploy/api' Application.<hr width=100% size=1 color=silver></H1>
    
            <h2> <i>Object reference not set to an instance of an object.</i> </h2></span>
    
            <font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">
    
            <b> Description: </b>An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
    
            <br><br>
    
            <b> Exception Details: </b>System.NullReferenceException: Object reference not set to an instance of an object.<br><br>
    
            <b>Source Error:</b> <br><br>
    
            <table width=100% bgcolor="#ffffcc">
               <tr>
                  <td>
                      <code>
    

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.</code>

                  </td>
               </tr>
            </table>
    
            <br>
    
            <b>Stack Trace:</b> <br><br>
    
            <table width=100% bgcolor="#ffffcc">
               <tr>
                  <td>
                      <code><pre>
    

    [NullReferenceException: Object reference not set to an instance of an object.]
    CloneDeploy_Services.SettingServices.GetSetting(String settingName) +378
    CloneDeploy_Services.SettingServices.GetSettingValue(String settingName) +76
    CloneDeploy_App.Startup.Configuration(IAppBuilder app) +224

    [TargetInvocationException: Exception has been thrown by the target of an invocation.]
    System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) +0
    System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) +128
    System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +146
    Owin.Loader.<>c__DisplayClass12.<MakeDelegate>b__b(IAppBuilder builder) +93
    Owin.Loader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder) +209
    Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) +842 Microsoft.Owin.Host.SystemWeb.OwinBuilder.Build(Action1 startup) +51
    Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() +101
    System.Threading.LazyInitializer.EnsureInitializedCore(T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory) +136
    Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context) +162
    System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers) +583
    System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context) +169
    System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +396
    System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +333

    [HttpException (0x80004005): Exception has been thrown by the target of an invocation.]
    System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +525
    System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +124
    System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +700
    </pre></code>

                  </td>
               </tr>
            </table>
    
            <br>
    
            <hr width=100% size=1 color=silver>
    
            <b>Version Information:</b>&nbsp;Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.2114.0
    
            </font>
    
    </body>
    

    </html>
    <!--
    [NullReferenceException]: Object reference not set to an instance of an object.
    at CloneDeploy_Services.SettingServices.GetSetting(String settingName)
    at CloneDeploy_Services.SettingServices.GetSettingValue(String settingName)
    at CloneDeploy_App.Startup.Configuration(IAppBuilder app)
    [TargetInvocationException]: Exception has been thrown by the target of an invocation.
    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass12.<MakeDelegate>b__b(IAppBuilder builder)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinBuilder.Build(Action1 startup)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint()
    at System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func`1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
    [HttpException]: Exception has been thrown by the target of an invocation.
    at System.Web.HttpRuntime.FirstRequestInit(HttpContext context)
    at System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context)
    at System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context)



  • Hey,

    Is it possible to reinstall clonedeploy 1.3.0 when i had clonedeploy 1.2.0 installed before? I read that this could cause problems?

    Thanks



  • Hi , I have exactly the same problem as zodiacs... after restart the IIS Service at the login page shows "Unknown Error With Token API", when i try to login. I can't finish the last steps settings.
    I make a clean upgrade with no message errors. Can anyone help us?



  • Are you certain it's the exact same exception message? Can you post your log file?



  • See log file from C:\Program Files (x86)\clonedeploy\frontend\private\logs and a printscreen about error login.

    at event viewer from windows i detect this error too:

    Log Name: Application
    Source: ASP.NET 4.0.30319.0
    Date: 06/11/2017 11:44:56
    Event ID: 1309
    Task Category: Web Event
    Level: Warning
    Keywords: Classic
    User: N/A
    Computer: ATPSRVDC-OPO01.AltranPT.Corp
    Description:
    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 06/11/2017 11:44:56
    Event time (UTC): 06/11/2017 11:44:56
    Event ID: 00c1e13c5eaf42e8b864f9995a611de7
    Event sequence: 2
    Event occurrence: 1
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/1/ROOT/clonedeploy/api-5-131544422904471767
    Trust level: Full
    Application Virtual Path: /clonedeploy/api
    Application Path: C:\Program Files (x86)\clonedeploy\application\
    Machine name: ATPSRVDC-OPO01

    Process information:
    Process ID: 5096
    Process name: w3wp.exe
    Account name: IIS APPPOOL\DefaultAppPool

    Exception information:
    Exception type: TargetInvocationException
    Exception message: Exception has been thrown by the target of an invocation.
    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() at System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

    Object reference not set to an instance of an object.
    at CloneDeploy_Services.SettingServices.GetSetting(String settingName)
    at CloneDeploy_Services.SettingServices.GetSettingValue(String settingName)
    at CloneDeploy_App.Startup.Configuration(IAppBuilder app)

    Request information:
    Request URL: http://localhost/clonedeploy/api/Token
    Request path: /clonedeploy/api/Token
    User host address: ::1
    User:
    Is authenticated: False
    Authentication Type:
    Thread account name: IIS APPPOOL\DefaultAppPool

    Thread information:
    Thread ID: 92
    Thread account name: IIS APPPOOL\DefaultAppPool
    Is impersonating: False
    Stack trace: at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() at System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

    Custom event details:

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="ASP.NET 4.0.30319.0" />
    <EventID Qualifiers="32768">1309</EventID>
    <Level>3</Level>
    <Task>3</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-11-06T11:44:56.000000000Z" />
    <EventRecordID>55748</EventRecordID>
    <Channel>Application</Channel>
    <Computer>ATPSRVDC-OPO01.AltranPT.Corp</Computer>
    <Security />
    </System>
    <EventData>
    <Data>3005</Data>
    <Data>An unhandled exception has occurred.</Data>
    <Data>06/11/2017 11:44:56</Data>
    <Data>06/11/2017 11:44:56</Data>
    <Data>00c1e13c5eaf42e8b864f9995a611de7</Data>
    <Data>2</Data>
    <Data>1</Data>
    <Data>0</Data>
    <Data>/LM/W3SVC/1/ROOT/clonedeploy/api-5-131544422904471767</Data>
    <Data>Full</Data>
    <Data>/clonedeploy/api</Data>
    <Data>C:\Program Files (x86)\clonedeploy\application</Data>
    <Data>ATPSRVDC-OPO01</Data>
    <Data>
    </Data>
    <Data>5096</Data>
    <Data>w3wp.exe</Data>
    <Data>IIS APPPOOL\DefaultAppPool</Data>
    <Data>TargetInvocationException</Data>
    <Data>Exception has been thrown by the target of an invocation.
    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() at System.Threading.LazyInitializer.EnsureInitializedCore[T](T&amp; target, Boolean&amp; initialized, Object&amp; syncLock, Func1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

    Object reference not set to an instance of an object.
    at CloneDeploy_Services.SettingServices.GetSetting(String settingName)
    at CloneDeploy_Services.SettingServices.GetSettingValue(String settingName)
    at CloneDeploy_App.Startup.Configuration(IAppBuilder app)

    </Data>
    <Data>http://localhost/clonedeploy/api/Token</Data>
    <Data>/clonedeploy/api/Token</Data>
    <Data>::1</Data>
    <Data>
    </Data>
    <Data>False</Data>
    <Data>
    </Data>
    <Data>IIS APPPOOL\DefaultAppPool</Data>
    <Data>92</Data>
    <Data>IIS APPPOOL\DefaultAppPool</Data>
    <Data>False</Data>
    <Data> at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() at System.Threading.LazyInitializer.EnsureInitializedCore[T](T&amp; target, Boolean&amp; initialized, Object&amp; syncLock, Func1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
    </Data>
    </EventData>
    </Event>



  • This appears to the same problem. It is complaining it can't get the value of a specific setting, but not sure which one. Like the other post it seems like the database isn't upgrading properly. Would you mind attaching a database dump? Do you need instructions?



  • The dump is the file create at the step13?
    I appreciate if you can send instructions.



  • Yes, run it again now that it's updated, rename it to something else so the original backup doesn't get overwritten. Send me a pm with the db attached.



  • Hi again,
    I detect my mistake!! at the step 15 i type ">" instead "<".... so i damaged the 1.3.0-update.sql file
    Finally i could login again and finish all the steps!! 🙂

    Unfortunately another problem occur after select clonedeploy option, at boot menu. Can you help me wiht the follow message error:
    ** Downloading Core Scripts **
    ...... Could not Downloading Script
    ...... Response Code: 403



  • Did you complete these final steps?

    [code]Find the BaseURL and remove the service/client.asmx piece
    Change the Tftp Server Ip to your server ip address
    Save the settings
    Click Yes to create a new boot menu when prompted
    Click Create Boot Files[/code]



  • I already done it but I repeated again (i click yes to create a boot menu and click Create boot files).
    The error occur at the boot menu, when i choose the 2ª option (clonedeploy). If I choose the last one (client console) everything runs well and prompted for user and password.



  • Are you using universal token for anything?



  • Sorry for the question...but how can i see that?
    You are talking about the option at the Security menu? I have that field empty...



  • Do you have all security options set to yes?



  • All except "Add Computer Requires Login:"
    Again about the security menu... do i need to generate the Universal token?



  • That can't be set to no if the universal token is empty.