Upgrade from 1.2.0 to 1.3.0, no mapping between...



  • See log file from C:\Program Files (x86)\clonedeploy\frontend\private\logs and a printscreen about error login.

    at event viewer from windows i detect this error too:

    Log Name: Application
    Source: ASP.NET 4.0.30319.0
    Date: 06/11/2017 11:44:56
    Event ID: 1309
    Task Category: Web Event
    Level: Warning
    Keywords: Classic
    User: N/A
    Computer: ATPSRVDC-OPO01.AltranPT.Corp
    Description:
    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 06/11/2017 11:44:56
    Event time (UTC): 06/11/2017 11:44:56
    Event ID: 00c1e13c5eaf42e8b864f9995a611de7
    Event sequence: 2
    Event occurrence: 1
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/1/ROOT/clonedeploy/api-5-131544422904471767
    Trust level: Full
    Application Virtual Path: /clonedeploy/api
    Application Path: C:\Program Files (x86)\clonedeploy\application\
    Machine name: ATPSRVDC-OPO01

    Process information:
    Process ID: 5096
    Process name: w3wp.exe
    Account name: IIS APPPOOL\DefaultAppPool

    Exception information:
    Exception type: TargetInvocationException
    Exception message: Exception has been thrown by the target of an invocation.
    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() at System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

    Object reference not set to an instance of an object.
    at CloneDeploy_Services.SettingServices.GetSetting(String settingName)
    at CloneDeploy_Services.SettingServices.GetSettingValue(String settingName)
    at CloneDeploy_App.Startup.Configuration(IAppBuilder app)

    Request information:
    Request URL: http://localhost/clonedeploy/api/Token
    Request path: /clonedeploy/api/Token
    User host address: ::1
    User:
    Is authenticated: False
    Authentication Type:
    Thread account name: IIS APPPOOL\DefaultAppPool

    Thread information:
    Thread ID: 92
    Thread account name: IIS APPPOOL\DefaultAppPool
    Is impersonating: False
    Stack trace: at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() at System.Threading.LazyInitializer.EnsureInitializedCore[T](T& target, Boolean& initialized, Object& syncLock, Func1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

    Custom event details:

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <System>
    <Provider Name="ASP.NET 4.0.30319.0" />
    <EventID Qualifiers="32768">1309</EventID>
    <Level>3</Level>
    <Task>3</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-11-06T11:44:56.000000000Z" />
    <EventRecordID>55748</EventRecordID>
    <Channel>Application</Channel>
    <Computer>ATPSRVDC-OPO01.AltranPT.Corp</Computer>
    <Security />
    </System>
    <EventData>
    <Data>3005</Data>
    <Data>An unhandled exception has occurred.</Data>
    <Data>06/11/2017 11:44:56</Data>
    <Data>06/11/2017 11:44:56</Data>
    <Data>00c1e13c5eaf42e8b864f9995a611de7</Data>
    <Data>2</Data>
    <Data>1</Data>
    <Data>0</Data>
    <Data>/LM/W3SVC/1/ROOT/clonedeploy/api-5-131544422904471767</Data>
    <Data>Full</Data>
    <Data>/clonedeploy/api</Data>
    <Data>C:\Program Files (x86)\clonedeploy\application</Data>
    <Data>ATPSRVDC-OPO01</Data>
    <Data>
    </Data>
    <Data>5096</Data>
    <Data>w3wp.exe</Data>
    <Data>IIS APPPOOL\DefaultAppPool</Data>
    <Data>TargetInvocationException</Data>
    <Data>Exception has been thrown by the target of an invocation.
    at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() at System.Threading.LazyInitializer.EnsureInitializedCore[T](T&amp; target, Boolean&amp; initialized, Object&amp; syncLock, Func1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)

    Object reference not set to an instance of an object.
    at CloneDeploy_Services.SettingServices.GetSetting(String settingName)
    at CloneDeploy_Services.SettingServices.GetSettingValue(String settingName)
    at CloneDeploy_App.Startup.Configuration(IAppBuilder app)

    </Data>
    <Data>http://localhost/clonedeploy/api/Token</Data>
    <Data>/clonedeploy/api/Token</Data>
    <Data>::1</Data>
    <Data>
    </Data>
    <Data>False</Data>
    <Data>
    </Data>
    <Data>IIS APPPOOL\DefaultAppPool</Data>
    <Data>92</Data>
    <Data>IIS APPPOOL\DefaultAppPool</Data>
    <Data>False</Data>
    <Data> at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
    at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters)
    at Owin.Loader.DefaultLoader.<>c__DisplayClass1.<LoadImplementation>b__0(IAppBuilder builder)
    at Microsoft.Owin.Host.SystemWeb.OwinAppContext.Initialize(Action1 startup) at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.InitializeBlueprint() at System.Threading.LazyInitializer.EnsureInitializedCore[T](T&amp; target, Boolean&amp; initialized, Object&amp; syncLock, Func1 valueFactory)
    at Microsoft.Owin.Host.SystemWeb.OwinHttpModule.Init(HttpApplication context)
    at System.Web.HttpApplication.RegisterEventSubscriptionsWithIIS(IntPtr appContext, HttpContext context, MethodInfo[] handlers)
    at System.Web.HttpApplication.InitSpecial(HttpApplicationState state, MethodInfo[] handlers, IntPtr appContext, HttpContext context)
    at System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context)
    at System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext)
    </Data>
    </EventData>
    </Event>



  • This appears to the same problem. It is complaining it can't get the value of a specific setting, but not sure which one. Like the other post it seems like the database isn't upgrading properly. Would you mind attaching a database dump? Do you need instructions?



  • The dump is the file create at the step13?
    I appreciate if you can send instructions.



  • Yes, run it again now that it's updated, rename it to something else so the original backup doesn't get overwritten. Send me a pm with the db attached.



  • Hi again,
    I detect my mistake!! at the step 15 i type ">" instead "<".... so i damaged the 1.3.0-update.sql file
    Finally i could login again and finish all the steps!! 🙂

    Unfortunately another problem occur after select clonedeploy option, at boot menu. Can you help me wiht the follow message error:
    ** Downloading Core Scripts **
    ...... Could not Downloading Script
    ...... Response Code: 403



  • Did you complete these final steps?

    [code]Find the BaseURL and remove the service/client.asmx piece
    Change the Tftp Server Ip to your server ip address
    Save the settings
    Click Yes to create a new boot menu when prompted
    Click Create Boot Files[/code]



  • I already done it but I repeated again (i click yes to create a boot menu and click Create boot files).
    The error occur at the boot menu, when i choose the 2ª option (clonedeploy). If I choose the last one (client console) everything runs well and prompted for user and password.



  • Are you using universal token for anything?



  • Sorry for the question...but how can i see that?
    You are talking about the option at the Security menu? I have that field empty...



  • Do you have all security options set to yes?



  • All except "Add Computer Requires Login:"
    Again about the security menu... do i need to generate the Universal token?



  • That can't be set to no if the universal token is empty.



  • I change all the security options to yes (the token field disappear) and know i think everything is working fine. I already test upload and deploy a new image and deploy an existent image with success!!
    Thanks for your help!!

    I only noted a behavior does n´t occur before: When i tried to upload an image i get the follow message (after choose the image name):
    ** An Error has occurred **
    "Hibernation must be Completely disable Before resizing a partition. From an elevated CMD Prompt run powercfg.exe /h off"

    After run the indicated command its possible execute the upload.
    This is a new feature/validation executed before start ?