GUI Login failed: Unknown Error With Token API



  • Hey,

    i've installed clonedeploy 1.3.0 on a Ubuntu linux x64 16.04.3 LTS
    No errors during installation, but now i can't login.
    I tried clonedeploy and password, but I get the error message "Unknown Error With Token API"
    I tried to reset the password in mysql, but no good.

    What am I doing wrong?



  • Attach the log files found in:
    /var/www/html/clonedeploy/frontend/private/logs
    /var/www/html/clonedeploy/api/private/logs



  • The Api log is empty



  • Your mysql password is wrong in Web.config, did you update it?

    <h2 class="exceptionMessage">Access denied for user 'root'@'localhost' (using password: YES)</h2>



  • My bad!!
    I did'nt change Web.config like it said in the manual.
    Now it works! Thanks a lot!

    xx_marker1_xx to your cduser database password you created earlier
    On that same line change Uid=root to Uid=cduser
    xx_marker2_xx to some random characters(a-z and numeric only), probably should be a minimum of 8



  • Hi clonedeploy,

    Like GEMOT above i have a install of CloneDeploy 1.3.0 on a Ubuntu 16.04 LTS server and am experiencing the same issue (Unknown Error With Token API error on login). I've double checked the password / username entries in the Web.config which were configured during the install with no success.

    I've attached the error logs you noted in the previous post for review. Greatly appreciate any assistance. Thanks
    Brent Kudla



  • The error seems to indicate it can't connect to the sql server.
    [quote]Unable to connect to any of the specified MySQL hosts[/quote]

    Is mysql running? Did the database commands run successfully?



  • I am also facing the same issue, I already updated MySQL user details according to the setup but unfortunately unable to the login web panel and showing same error "Unknown Error With Token API".
    Please help on the same.