Proxy dhcp problem



  • Hello together,

    i have a problem with the proxy dhcp tool. Screenshot and config file are attached.
    Both clonedeploy and proxy dhcp is the newest version. I have tried to work both under ubuntu 16.04lts with all updates. Mono is updated too. Without proxy dhcp, with windows dhcp, works clonedeploy. But the scenario that i need, presupposes a proxy dhcp. I´ve tested proxy dhcp under win10, with the same result. I think, anything under clonedeploy is wrong configured, but i don´t know what.
    Proxy DHCP under clonedeploy ist enabled. Boot files are generated.
    Does anybody know, what the solution is ?

    THX for help



  • Are you already running a DHCP-server on this machine?
    It seems proxydhcp can't bind to port 67 because the port is already in use.
    This usually indicates another DHCP-server on the same machine.



  • Ok, i´ve forgotten to start mono proxydhcp with root rights. Look at my screenshot, what is the errors with tftp ? And when i start the client, proxy dhcp realize it, but clonedeploy doesn´t responds for.
    Any ideas ?



  • The newest version of the proxy server, monitors the tftp servers to see which ones are up for failover and load balancing. The upgrade to 1.3.0 forgot to include a necessary file, a new install is not effected. Place this file in your tftpboot folder.



  • It changed only the error code from 1 to 8. But the error is the same. Look at my screenshots please.



  • What are you using for tftp server? It can't get that file for some reason.



  • Another option is to disable the cluster check in you config file

    [code]check-tftp-cluster=false[/code]



  • tftpd-hpa
    [attachment:59e8a7c771fab]



  • The first problem ist done, no errors with tftp. It was the cluster setting. Now i can boot to clonedeploy.
    Rhanks for support.



  • When i start mono dhcp proxy as a daemon, where i can see, that is working like the screenshots above ?



  • You need a systemd service file.
    Make a file in /etc/systemd/system/multi-user.target.wants/
    named cd_proxyd.service

    Add the following
    [code][Unit]
    Description=CloneDeploy Proxy DHCP
    After=network.target tftpd-hpa.service apache2.service
    [Service]
    ExecStart=/usr/bin/mono /opt/cd_proxyd/cd_proxyd.exe --daemon
    Type=simple
    [Install]
    WantedBy=multi-user.target[/code]

    Change paths as necessary. This is what I use on CentOS. Not sure if ubuntu is exactly the same but should be close



  • Then you could do service cd_proxyd status or whatever you named the file



  • OK, i will try it, thanks for help