Proxy DHCP Reservation: 500 Internal Server Error

  • In my C/D v1.3.0 installation (upgraded from v1.2.1) on Ubuntu 16..04, when I got to [i]Computers > View a computer[/i] at the URL:

    When I clock the [i]Proxy DHCP Reservation[/i] I get a [b]500 Internal Server Error[/b]

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.
    Apache/2.4.18 (Ubuntu) Server at ${CLONEDEPLOY_HOST} Port 80

    My error.log file is attached

  • Does this happen for all computers or only one's that were there before the upgrade?

    Can you upgrade mono to the latest version? It looks like you are on 4.something, the latest is 5.

  • I am using the stock mono that comes with Ubuntu 16.04
    $ mono --version
    Mono JIT compiler version (tarball Fri Oct 13 21:51:45 UTC 2017)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors.
    TLS: __thread
    SIGSEGV: altstack
    Notifications: epoll
    Architecture: amd64
    Disabled: none
    Misc: softdebug
    LLVM: supported, not enabled.
    GC: sgen (concurrent by default)

    All my hosts were defined in v1.2.1 (and I ported the database over to v1.3.0)
    I also have the old v1.2.1 running (the new host is a clone of the old one, upgraded) and in the old one I don't see this error.

    Should I delete my old computer entry and re-create it (with the same data)?

  • Just create a fake computer with fake mac for now and see if it works.

  • Yes it crashes also with the fake computer entry.

  • Is there anything in the clonedeploy logs, application or frontend?

    Try clearing the mono cache.
    Stop apache
    remove all files in /tmp
    Restart apache

  • I was able to replicate this. It's an issue with mono. Works fine on Windows. I'll see what I can find out.

  • Just for posterity: I tried to stop apache2, clear /tmp and restart apache2 -- got the same results.

    I didn't know what logs should I look at, but if you need any other information I will do my best to post it here.


  • So for some reason the frontend on Mono doesn't like when the api responds with null, even though it is correctly accounted for. In this case the computer doesn't have an existing proxy entry, so the api returns null. I have no idea why this crashes mono but works fine on Windows. I changed the api to return a new object instead of null which should fix the issue, but I'm worried how many others are being affected by this. Here is the fix.

    Overwrite the existing file in your api/bin folder

  • That fixed it. Thanks.

    Will post in this thread in case I will find similar behavior elsewhere.