SMB Share Failure (Tried the guide)



  • I am getting an SMB Share Failure when I go to upload an image to the server.

    I have tried all of the troubleshooting steps up to step 6 here: http://clonedeploy.org/docs/smb-troubleshooting/

    On step 6, when I enter the command:

    mount -t cifs //[server-ip]/cd_share /storage -o user=cd_share_rw,pass=[cd_share_rw pass],dom=workgroup,vers=2.0

    It comes back with a Permission Denied error.

    I have double-checked the password and the share permissions, and have completed the recommended fixes for this issue in the guide, but I still cannot get this to work. Any suggestions?

    • shared permissions are correct
    • security permissions are correct
    • password is correct
    • firewalls are off, etc.


  • Can you connect to the share from another windows machine? Are there any special characters in your password?



  • I cannot connect to it from another windows machine. It states that i do not have permission. Usually when this happens it lets me enter credentials, but this time it went straight to access denied. It will allow me to connect only when i change the folder permissions and add my username.

    There are no special characters in my password, just letters and numbers.



  • You need to map the drive using alternate credentials.



  • I tried mapping the drive using alternate credentials, but was still not able to connect. I reset the passwords to cd_share_ro and cd_share_rw one more time in windows and then it worked. After getting that to work, the SMB share mounted successfully!

    Thank you for your help! I must have forgotten to reset the passwords locally after resetting them in the CloneDeploy web interface.

    Could you add the mapping network drive step to the troubleshooting guide? I think that many people would benefit from it.