To anyone using Clonedeploy and worried about High Sierra

  • So we all know now that Apple has made it not possible to upgrade machines from Sierra to High Sierra using standard imaging.  I believe High Sierra and later will still be able to be imaged, but going from Sierra to High Sierra is essentially like going from OS 9 to OS X.  I just want to let people know that CloneDeploy can still be used if you build a NetInstall set instead of a NetRestoret set.  This allows you still run a windows server running clonedeploy to deploy to macs.  What's different about the 2 is that NetRestore would just copy an image down to the drive and call it a day.  Well in order for any machine to run High Sierra, the client is required to do a firmware update that can only be triggered via an actual install.  So that being said, just create a second Clonedeploy server and instead of creating a NetRestore.nbi  use Automator or System Image utility to create a NetInstall.nbi.  This will allow you to "netboot" your Mac clients to the actual High Sierra installer Via Netinstall and perform the upgrade.  
     We also use Munki here where i work too, so we just add the munkitools.pkg to the automator workflow so that once the OS finishes installing, it installs munkitools and the client checks in with munki and pulls down and installs the required applications for the device.  This is the best workaround i have found so far until we get all our clients to High Sierra where we can then mess around with testing imaging again.

    Hope this helps,

  • Thanks for the update. In addition to this, there is apparently a way to extract the necessary firmware updates which could then be installed during imaging. Never been tested, but if anyone wants to try. Here is a guide on how to extract.

  • Update on imaging from Sierra to High Sierra. After upgrading to CloneDeploy 1.3.3 and working though a couple of hick-ups getting the NetBoot service working I have been able to image Sierra to High Sierra successfully. I did not have to use the extracted firmware package as chronicled in the link you provided above. Initially when imaging I received a warning from CloneDeploy (thank you for putting that bit of code in) that imaging hfsf+ to apfs could result in an unbootable drive. The result, however has been a perfectly bootable drive. The only issue is that the volume does not get blessed at the end of imaging so initial boot will be a question mark folder. This is reminiscent of when you first added Mac support and PXE booting obviously did not have access to the mac command line and could not bless the drive. So my question is this: Is it possible to add a post script to be run at the end of the Mac imaging to bless the drive? If so where would I add this in CloneDeploy? Thanks for all the hard work, and hanging in there bucking the Apple Juggernaut.

  • The volume should get blessed. It is already in the script. It's possible that it may not be working correctly. What command are you using to fix it? Can you attach the deploy log.

  • Of course I tested again today with two devices that imaged just fine from 10.12 to 10.13 with no issue. Here's the log for the first device I tested where on reboot I had a ? folder however once choosing the volume Macintosh HD it booted just fine.

  • In CloneDeploy 1.2.0 there was a section for editing core scripts in the Global > Imaging Scripts setting. I cannot seem to find that in my deployment of 1.3.3. I just want to make sure I'm not missing some crucial piece of the server setup. There have been a few quirks in upgrading as you know. So if there is a different location or specialized account (although I'm logged in as an admin). Thanks

  • It's now in admin settings

  • Awesome Thanks! What script has the bless command? Or if you used a different command what is it?

  • It's in mie_deploy.

    I run this command.
    [code]systemsetup -setstartupdisk "$osx_target_volume" >> $CLIENT_LOG 2>&1[/code]

  • Thanks

  • Sorry to take so long to respond to this thread. I've been busy with some other stuff. I think I figured out why imaging Sierra to High Sierra does not properly set the boot drive. If I run the command while booted into Clone Deploy (1.3.3) I get an error "Setting startup disk not allowed while System Integrity Protection (SIP) is enabled.

    It looks like this command can only be used from the recovery partition. I can disable it before uploading an image and this fixes the issue with the ? boot folder. i.e. systemsetup is able to set the startup disk. However this leaves the device without SIP enabled which may or may not be detrimental to the final deployment (I'm sure Apple would view it as detrimental).

    Of course it can be reenabled from the recovery partition. However I find it easier to leave it enabled and select Macintosh HD from the Startup Manager. Curiously enough this only happens when imaging from HFS+ to APFS (Sierra to High Sierra), but I bet that has something to do with the update to firmware since the setting carries over to the target machine.