Multicast problem



  • At the beginning I say that I'm new to Clonedeploy and to this type of software so there's a lot I don't know.
    At the small company I work we used linux server with Clonedeploy 1.1 which was installed and configured by former employee. We used it to install small batch of PCs at one time by "start on demand multicast" (every time it's different batch, different MACs etc.). Unfortunately hdd crashed so I had to configure Clonedeploy by myself on new PC. I installed latest version (1.3.2) on Win7Pro PC which works in separate network (not connected to our local network or internet, just pc and switch). I was able to configure Clonedeploy and upload some images but when I tried to install it on PCs I get to this point and just nothing happens:

    ** Starting Image Download For /dev/sda1 **
    Udp-receiver 20120424
    UDP receiver for (stdout) at 192.168.1.25 on eth0
    Partclone v0.2.90 http://partclone.org
    Starting to restore image (-) to device (/dev/sda1)

    As I said I'm new so I could do something wrong. Could you suggest what may be wrong?



  • Have you tried multicasting with just a single computer



  • I tried with one and two computers, in both cases the same result. Deploying works fine.



  • try adding [code]--blocksize 700[/code] to the multicast sender arguments



  • I already tried that, I found that solution in different conversation.



  • Can you attach the multicast log?



  • From Admin > Logs? There are no logs from unsucessful sessions.
    Unless you mean log from c:\program files\clonedeploy\application\private\logs - there's log from today's multicast:

    12-13-17 08:49 Starting Multicast Session With The Following Command:
    cmd.exe /c ""C:\Program Files (x86)\clonedeploy\application\private\apps\udp-sender.exe" --file "C:\Program Files (x86)\clonedeploy\cd_dp\images\image1\hd0\part1.ntfs.lz4" --portbase 9014 --min-receivers 1 --ttl 32 --blocksize 700 & "C:\Program Files (x86)\clonedeploy\application\private\apps\udp-sender.exe" --file "C:\Program Files (x86)\clonedeploy\cd_dp\images\image1\hd0\part2.ntfs.lz4" --portbase 9014 --min-receivers 1 --ttl 32 --blocksize 700"



  • Looks normal. Do you have more than one nic on the server?



  • No, there's only one.
    I will reinstall everything and check once again.



  • I doubt reinstalling will help. Is the windows firewall on?



  • Yes, it is. I forgot about that. Should I change something in firewall settings?



  • Exceptions are created during install, but in case something didn't work, I would disable for testing. If it works we can add the correct exceptions.



  • [b]Turning the Firewall off worked for me[/b]. Its on an isolated network so I didn't need to dig deeper in what ports needed to be open sadly but its working now!



  • Sorry for not replying. I didn't have time to work on it during last two weeks.
    Disabling firewall worked. For the moment it's disabled, later I will try to find out what exception should be created.