Unknown error with token API



  • Trying to upgrade from 1.3.0 to 1.3.3 on Windows 10 x 64bit.
    After merging and overwriting any existing files - on login to the web portal I receive an Unknown error with token API error.

    I have tried on a fresh install after it failing with the same error on an existing install.

    I have enclosed the CloneDeployFE.log .

    Any ideas?



  • Hangfire wasn't modified so that error doesn't make sense. Can you verify the version of Hangfirecore in program files\clonedeploy\application\bing. Just right click and select properties and select details



  • I don't have the path above but in C:\Program Files (x86)\clonedeploy\application I have the following. Which file do I need the properties of?

    thanks again



  • I don't know why, but you are missing all of the hangfire files.

    You can grab them all here and put them in that directory
    https://github.com/cdadmin/clonedeploy/tree/master/CloneDeploy-App/bin



  • Hi thanks I'll try that. Just out of curiosity I have reverted snapshot back to 1.3.0 version which allows web login and there is no Hangfire files within the Application folder either?



  • Copying the Hangfire files into the Application folder hasn't worked either unfortunately.



  • Something is not adding up. I don't see how you could ever run 1.3.x without the hangfire dlls. Is it possible that you have multiple versions running? As a test I did a clean install of 1.3.0, the hangfire dlls were installed. I deleted the hangfire files and received the same error that you posted. I put them back and everything was fine. Do you have any antivirus running?



  • Hi I reverted back for a clean install and this time instead of installing from a shared folder I copied locally into Virtualbox and installed. Hangfire files appeared and I have now also upgraded successfully.
    Thanks for your help. And I I think our Watchguard or Sophos interfered with the install as you suggested.