Admin > Distribution Points > Location > Remote: deploy error



  • We are upgraded from 1.2.1 to 1.3.0 + [url=https://forum.clonedeploy.org/633]a patch[/url] that put us effectively on 1.3.1. And we overall happy with the upgrade.

    Our images resides on a SMB share, and it works fine, however in
    Our [b]Admin > Distribution Points > Location:[/b] is configured to be [b]Local[/b]. This setup work.

    But when I try to set it to [b]Remote[/b] and try to deploy a computer I get an:

    [code]
    ** Processing /dev/sda **

    Get hd_schema: profileId=7&clientHdNumber=0&newHdSize=120034123776&schemaHds=&clientLbs=512

    {"Message":"An error has occurred."}

    ** An Error Has Occurred **

    ...... Unknown Error Occurred While Determining Minimum HD Size Required. Check The Exception Log
    [/code]

    The full log is (identifying information was removed to protect the innocent):
    [code]
    ** Looking For Active Task For 12:34:56:78:90:ab..AC75D100-9149-11E4-B187-F44D3064AB83 **

    {"computerId":"false","task":"ond","taskId":null}

    ...... This Computer Was Not Found

    ** Looking For Active Task For 12:34:56:78:90:ab **

    {"computerId":"6","task":"deploy","taskId":"5371"}

    ...... Success

    Found deploy Task For This Computer

    ** Displaying Boot Arguments **

    BOOT_IMAGE=kernels/4.9.8x64 initrd=images/initrd.xz root=/dev/ram0 rw ramdisk_size=156000 consoleblank=0 web=http://clonedeploy.my-host.my-domain/clonedeploy/api/ClientImaging/ USER_TOKEN=012345678-90ab-cdef-0123-4567890abcdef MAC: 12:34:56:78:90:ab
    Linux client_console.localdomain 4.9.8 #1 SMP Thu Feb 9 09:35:08 EST 2017 x86_64 GNU/Linux

    Boot Image Version: 1008

    ** Verifying Active Task **

    computer_name=pm07 image_name=ubuntu-1404-x64-minimal profile_id=7 server_ip=clonedeploy.my-host.my-domain pre_scripts="" post_scripts="" file_copy=False sysprep_tags="" task_completed_action="Reboot" osx_target_volume="" munki_repo_url="" change_computer_name=true fix_bootloader=true partition_method=dynamic dp_id="1"

    ...... Success

    ** Checking Current Queue **

    ...... Complete

    ** Mounting SMB Share **

    ...... Connecting To Default
    mount: mounting //1.2.3.4/images on /storage failed: Operation not supported

    ...... Success

    ** Looking For Hard Drive(s) **

    ...... Displaying Available Devices
    RO RA SSZ BSZ StartSec Size Device
    rw 256 512 1024 0 159744000 /dev/ram0
    rw 256 512 4096 0 120034123776 /dev/sda
    rw 256 512 4096 2048 524288000 /dev/sda1
    rw 256 512 4096 1026048 119508787200 /dev/sda2
    Disk /dev/ram0: 152.4 MiB, 159744000 bytes, 312000 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes

    Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x000545ff

    Device Boot Start End Sectors Size Id Type
    /dev/sda1 * 2048 1026047 1024000 500M 83 Linux
    /dev/sda2 1026048 234441647 233415600 111.3G 8e Linux LVM

    ...... Found Drive(s)

    ...... Drive(s): /dev/sda

    ** Processing /dev/sda **

    Get hd_schema: profileId=7&clientHdNumber=0&newHdSize=120034123776&schemaHds=&clientLbs=512

    {"Message":"An error has occurred."}

    ** An Error Has Occurred **

    ...... Unknown Error Occurred While Determining Minimum HD Size Required. Check The Exception Log

    Yes No

    Tasks History 
    

    0 Active Task(s)

    No Active Tasks
    [/code]

    Naturally I keeping it [b]Local[/b] for now, but I suspect this isn't the optimal setting we could use. What am I missing?



  • The remote option in the gui only works on Windows, since it uses native windows libraries to mount the share, I haven't found anything to do the same in Mono. You can work around it by just mounting the share on the server. You can read more about it here.
    http://clonedeploy.org/docs/image-storage-linux/