Freenas Cannot Launch CloneDeploy Web Interface



  • I cannot launch CloneDeploy web Interface from any computer on my network. I've tried different systems win 7,10, and Linux. I've also tried different browsers I keep getting This site can’t be reached JAIL-IP/clonedeploy refused to connect, or make sure you've got the right web address. Any help to figure this out would be great.



  • Did you remember to enable the plugin after you installed it? Sounds silly, but many people forget that step.



  • Just figured that out. Came here to post an update to the problem and seen your comment. Thanks for the quick reply. I can't believe I missed something so silly.



  • I'm experience the same issue: Unable to access the CloneDeploy web interface.

    Except:

    • Jail status is running

    • I can ping the jail

    • Confirmed jail network works via jail shell and can ping from Jail to internal network and external (pinged gateway and 8.8.8.8)

    • Doesn't appear a web server is running?
      [code]root@clonedeploy_1:/ # service -e
      /etc/rc.d/cleanvar
      /etc/rc.d/newsyslog
      /etc/rc.d/syslogd
      /etc/rc.d/virecover
      /etc/rc.d/motd
      /usr/local/etc/rc.d/mysql-server
      /etc/rc.d/cron [/code]

    • Nothing is listening on port 80:

    [code] root@clonedeploy_1:/ # sockstat -4 -l
    USER COMMAND PID FD PROTO LOCAL ADDRESS FOREIGN ADDRESS
    root python2.7 63810 3 tcp4 192.168.0.203:12346 :
    mysql mysqld 63553 10 tcp4 6 *:3306 :
    root syslogd 63392 9 udp4 *:514 :
    root@clonedeploy_1:/ # netstat -a -n | grep LISTEN
    tcp4 0 0 192.168.0.203.12346 . LISTEN
    tcp46 0 0 *.3306 . LISTEN [/code]

    *I've done a post config jail restart AND physical machine reboot.

    I used this guide: http://clonedeploy.org/docs/install-on-freenas/
    Jail Plug version is 1.0.1. FN Version is FreeNAS-9.10-STABLE-201605240427 (64fcd8e)



  • You probably need to enable the plugin as above.



  • I have, as listed on step 4.

    "Still in Plugins, select the Installed tab and enable CloneDeploy"

    Also, I verified the jail is on.