Multicast on Vlans

  • Hi,

    I have bees as far as I could but but right now I'm on a dead end.

    I installed CloneDeploy on an Ubuntu 16.04 following documentation.
    My server has several Vlan Interfaces.
    Right now I'm doing test on the root interface ens32 and the vlan 122 interface ens32.122

    As far as I understood to support vlans several things has to be done.

    On default vlan with all default settings:
    -Registering, Unicast and multicast work.

    On Vlan 122:
    Registering, Unicast work
    Mutlicast fail but it's not explicit.

    In the client interface I choose Multicast, then I select the session.
    The Multicast process launch (not the mulitcast itself), till the pc arrives on start download ...
    and nothing happen, no error
    A this moment on the web server I have :
    for Status, Type, queue, partition, elapsed
    3, ondmulticast, 0, /dev/sda1, Please Wait...

    Regarding the config this is what i've done:

    -Create a image profile called S122, with this add in multicast option : [code]--interface ens32.122[/code]
    -In server settings add Alernate server IP :, url
    -Edit Boot Menu, modifying this line : [code]web=http://ServerIP/clonedeploy/api/ClientImaging[/code] replacing server IP with
    -In Custer defined server role as Primary with TFTP and Multicast checked.
    -In Cluster defined a new cluster group called C122 and checked server, roles and right distribution point (see just below)
    -In Cluster defined a new Distribution point with the following parameters :

    [code]Display Name: S122
    Server Ip / Name:
    Protocol: SMB
    Share Name: cd_share
    Domain / Workgroup: Workgroup
    Read/Write Username: cd_share_rw
    Read/Write Password: ******
    Read Only Username: cd_share_ro
    Read Only Password: ******
    Primary Distribution Point: not checked
    Queue Size: 3
    Physical Path:/cd_dp/[/code]

    According to me the client does not annouce itself to the multicast server.

    Did I forgot something?

    Before I use my wireshark, any idea? Any help would be very appreciated.

    Thanks by advance

  • Don't think it should matter, but I typically use the ip of the interface
    --interface ens32.122

  • Also on the image profile multicast receiver arguments, trying adding this

  • I had to unsheathe my wireshark. Still not working but the path goes on.

    Before your modification on the receiver
    When the client did its first request : the request was sent to without any answer of course.

    After your modification:
    The request is well sent to but then the server send an ICMP request to an unreachable port :


    Then the flow goes, but multicast won't start.

  • Let's remove CloneDeploy from the tests and just run a cmd line test.

    On Server:
    [code]echo "Hello" | udp-sender --portbase 9000 --ttl 32 --interface [ip][/code]

    Boot Client to debug mode
    [code]udp-receiver --portbase 9000[/code]

    Hello should be displayed on the client

  • It worked.

    Hello= 6 (48mbps)
    transfer complete.

    So the problem is elsewhere.

  • Can you attach the multicast log

  • [code]02-02-18 04:04 Starting Multicast Session With The Following Command:
    /bin/bash -c "cat "/cd_dp/images/W10-Remote/hd0/part1.ntfs.lz4" | udp-sender --portbase 9072 --min-receivers 1 --ttl 32 ; cat "/cd_dp/images/W10-Remote/hd0/part2.ntfs.lz4" | udp-sender --portbase 9072 --min-receivers 1 --ttl 32 "[/code]

    it does not include the --interface switch???

  • it does not include the --interface switch???

  • I'm may be the bug between the chair and the keyboard...
    this is my config and the way I launch the multicast :




  • Looks like a bug, it appears an on demand multicast never looks at the image profile multicast options, it instead looks at the global multicast options, however a group multicast does look at the image profile.

    [code]if (_isOnDemand)
    multicastArgs.ExtraArgs = SettingServices.GetSettingValue(SettingStrings.SenderArgs);
    if (!string.IsNullOrEmpty(_clientCount))
    multicastArgs.clientCount = _clientCount;
    multicastArgs.ExtraArgs = string.IsNullOrEmpty(_imageProfile.SenderArguments)
    ? SettingServices.GetSettingValue(SettingStrings.SenderArgs)
    : _imageProfile.SenderArguments;
    multicastArgs.clientCount = _computers.Count.ToString();

  • I tried to find this code somewhere with a grep,but no result.
    Where did you get this?

    Do you think it's easy to fix?

  • It's compiled code so you won't find it. The fix is easy, putting together a patch takes some time. I'll see what I can do next week.