Proxy DHCP stopped working

  • We arrive this morning to find that the systems stopped receiving PXE DHCP requests. A system will try to boot to PXE and never receives a file. I restarted the services and server but it's not working. I got it to work once but then has not since and am scratching my head.

    Here is my server:
    Windows Server 2008 r2
    CloneDeploy installed with ProxyDHCP

    Troubleshooting I've performed
    Restarting services and/or server
    Verified I can pull files via TFTP
    Regenerated boot files from the web interface
    Ran the ProxyDHCP in debug mode but nothing stood out

    Also, to get by while I attempt to figure this out, I built a USB drive. It will boot to the menu but goes to a black screen when I select either CloneDeloy or Console.

  • How far does the pxe boot go. Can you attach a screenshot of where it stops?
    When you ran proxy in debug mode did you see the requests coming in?

  • So, I spent 2 hours trying to troubleshoot this before I posted and within minutes of posting it we figured it was a PC connected to the network causing it. We had unplugged all the systems and now it's working reliably. I re-ran the proxy in debug mode and am seeing far fewer requests. I'm thinking one of the systems they unplugged was causing the issue.

    So, once I verified I could boot over PXE (tested 10 times) I then tried to test the USB drive. Found it is still not working. I get the Boot menu but then a black screen after selecting CloneDeploy or Console.

  • Did you use rufus to create the drive?

  • Yes I used Rufus and a Zalman enclosure during my testing. In both instances I utilized the ISO file I downloaded. I opened the configuration files in the ISO and verified they were all configured to the servers IP address correctly.

  • Might not work with a real hd or enclosure. Try a thumbdrive.

  • When I used Rufus it was on a thumbdrive. I had utilized the Zalman to verify it was not Rufus causing the issue.

  • What kernel did you select? Did you select a 64bit?

  • Kernel: 4.13.2x64
    Boot Image: initrd.xz

  • Update on the Proxy issue and one users should check into. We found the actual issue was our DHCP server had ran out of leases. To correct this we lowered the time an IP is leased for. This only occurred as we had imaged a few hundred system while we roll Windows 10 out.

    In the mean time, I'm still trying to troubleshoot the USB drive booting issue but that is probably a different issue altogether.