Partitioning error

  • Hello,

    i am applying an image created with 2 partitions, first one has 100 GB and the other 365GB. when deploying it, it skips the creation of the first one and only applies the second. If i change the profiles - deploy options - create partitions method to STANDARD, it deploys the first partition in a full sized 465GB partition and ignores the second one. No options in profiles or schema were altered when creating the image. Both upload and deployment were done in pxe mode (winpe) and we re running the latest CD version. Appreciate any help you can give me.

  • It sounds like standard is working properly. It only creates a standard partition layout and lays down a single partition you select. Dynamic appears to be the problem. Can you attach the upload log and the deploy log from a dynamic deploy?

  • Here are the logs, thank you

  • In WinPE it is assumed that the first partition is a boot partition and the image isn't copied back, instead a bootable partition is created on the fly. We should be able to tell it to copy the image over anyway.

    In admin settings->core scripts-> select wie_deploy.ps1 from the drop down
    At about line 115 you will find this
    [code]if(($($currentPartition.Number) -eq $bootPartition.PartitionNumber) -and $($hdSchema.PhysicalPartitionCount) -gt 1 )

    comment out the continue by putting a # in front


    Save the changes and try deploying again

    Not sure if this will work, but worth a shot

  • Ok, tried that but it halted the process. Sending you the new log...thanks

  • And even worse removing the # from that line to restore the original script now gets me the same error as the late log!

  • Anything else i can try? A custom script maybe?

  • I can't think of anything else at the moment. It seems like that should have worked. Your new logs don't really make sense. Have you tried it again, in case something strange was going on. Also, I responded to your other post with a new kernel you could try for the Linux imaging environment

  • Hi..i managed to make it work by quoting not just the line 115 but the entire block, lines 101 to 118. Doing this it successfuly aplied the partitions although i still had to run bcdboot command for the system to boot.

    As for the new kernel yes i tried but still.didnt boot up.

    Thank you