NTFS Resize Error

  • Hello,

    So I've got this issue when I try to deploy and image to Windows PCs. The NTFS partitions are not resizing properly, and I see Clonedeploy throwing the error. I already enabled the setting to use Dynamic Resizing since all the hard drives are the same size, but I'm still stuck with this error. Haven't seen it before. Log is attached. Wondering if you can help me!

    Warning, NTFS File System Did Not Resize Properly. Check Your Disk Size After Booting To Windows

    When I boot into Windows the C:\ partition is 512MB Free of 21.0GB in File Explorer but the Disk Management Snap-In shows the C:\ partition as 116.97GB...

  • log didn't attach

  • Whoops, here we go.

  • the log has a lot of extra characters for some reason, making it hard to read, did you export it or copy it? Also is this win10, if so what build?

  • Sorry I'm using a MAC so I tried to convert it to an easy txt file for you. But I see I could export now. Here are a few logs of different computers with same issue. Thanks!

  • It looks like an issue with the original upload. Is this Windows 10, if so what build?

  • Hmmm okay. It is Windows 10. Build 1709.

  • That's what I figured. 1709 changed something that is causing problems with ntfs resizing. I'm not sure anything can be done until I figure out the solution and provide a patch. Perhaps on the original image you could try not shrinking the partitions.

  • You could also try defragging the drive before re-uploading.

  • I noticed I can go to each computer and use diskpart on the C:\ volume to select it and use the "extend filesystem" command to get the computers correct again. But is there a way to automate that process with clonedeploy after the image is done?

    Additionally, I will try uploading the image again, I tried to find the log from that upload but its not in there for some reason. I could try not shrinking the partitions too as all the computers are the same model. But I would imagine it would dramatically extend the time its going to take to image these 20 or so computers, but as long as its works thats fine.

  • No way to automate it, that's basically what's failing. If you are using sysprep you could probably run something at the end to run those commands.

    It would not change the time, it still only captures used data. The shrink process is only to enable imaging to smaller drives.

  • Ok, Thanks for your help. Hope we can find a fix for 1709 soon! Good Product!