Can't Image an x86 Laptop

  • I installed CloneDeploy on a Windows 7 x64 VM just for testing.
    Set my existing DHCP Server to the correct parameters to instruct clients to PXE boot.
    Set a couple of clients to PXE boot.
    Worked like a charm!!! I can 'upload' an image from a VM and from hardware running Windows 10...
    ... as long as they are 64-bit!!!
    Tried to upload from an x86 laptop and I get nothing but errors:
    Something about "expected x64 but found i686 instead"
    Tried messing with boot menus but still getting the same error

  • You need to use a 32 bit kernel

  • I have tried re-generating the boot menu files so that the kernel section is bitness agnostic:
    kernel kernels\4.13.2

    Before re-generating, the boot menu (in the clonedeploy boot menu editor) was showing:
    kernel kernels\4.13.2x64

    I even removed the computer and re-registered it, but when I try to do an upload, all I get is:
    "Loading kernels\4.13.2x64.... ok"
    "Loading images\initrd.xz... ok"
    and then the same error:
    "This kernel requires an x86-64 CPU, but only detected an i686 CPU."
    "Unable to boot..."

  • If you are are uploading or deploying from a web task and not on demand, you need to set the kernel in the image profile pxe options

  • Well good-night.... that was easy enough!