Multicast Not Starting



  • Hello. Today I began the process of reimaging my labs but I am running into an option with multicasting. I add computers to a group in CloneDeploy, assign an image, and then start a multicast of the group. All of the members of the group join the multicast session but the reimaging process never starts. My server and PCs are on different subnets but I don't remember this being a problem last summer when I reimaged my PCs. I verified that I am able to start an on-demand deploy and it works just fine. I am running CD 1.3.5. Any suggestions? Thanks!



  • The different subnets could be an issue if the switches aren't setup correctly for multicasting? Was anything in your infrastructure changed b/w last year and now? Have you tried with a smaller group of computers, or even just one. If a multicast works with only 1 computer in the group it's most likely a switch config issue.



  • I checked and I'm not even able to start a multicast with one device. I'm going to check with our network team.



  • You could also try disabling the firewall on your server if it isn't already.



  • I first changed the IP on my CloneDeploy server to be on the same subnet as my clients but that still didn't work. So I turned off the Domain profile firewall on the server and that fixed it. Now I need to figure out why the firewall was blocking the mulitcast. Thanks.



  • Two rules are created during install that are usually enough.
    [code]netsh advfirewall firewall add rule name=udp-sender dir=in action=allow program="{app}\web\private\apps\udp-sender.exe" enable=yes profile=any
    netsh advfirewall firewall add rule name=udp-sender dir=out action=allow program="{app}\web\private\apps\udp-sender.exe" enable=yes profile=any[/code]



  • I looked in Windows Firewall with Advanced Security on the server and there were several entries for udp-sender in the inbound and outbound rules that were outdated from when CrucibleWDS was installed. So I removed all the udp-sender rules from inbound and outbound rules and then ran your two scripts. I then tried to multicast but it still didn't work. So under each rule under inbound and outbound, I changed the path to the udp-sender.exe from "{app}\web\private\apps\udp-sender.exe" to "%ProgramFiles% (x86)\clonedeploy\application\private\apps\udp-sender.exe" and now multicast works. Thanks for all of the suggestions!