Error while expanding "Volume Group" - System.NullReferenceException

  • Hello,

    I uploaded a CentOS7 image with a custom partition scheme, and I want to adjust what happens with the partitions during deployment.

    I open the image, go to Scheme, expand the LVM, and click the + to expand the Volume Group and there is a server error.

    I am running 1.3.3

    Any ideas? Thanks!

    [quote]Server Error in '/clonedeploy' Application.
    Object reference not set to an instance of an object.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [NullReferenceException: Object reference not set to an instance of an object.]
    CloneDeploy_ApiCalls.ImageSchemaAPI.GetLogicalVolumes(ImageSchemaRequestDTO schemaRequest) +167
    CloneDeploy_Web.views.images.ImageSpecs.btnVG_Click(Object sender, EventArgs e) +471
    System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e) +133
    System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +147
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1664[/quote]

  • Can you attach the schema?

  • See attached, is this what you need? When I click the + under Volume Group, the server error occurs.

  • In your images folder in your filesystem, find your image and inside is a file named schema. Please attach it.

  • Here you go. In case it helps, here's how I did the partitioning.

    CentOS7 Custom Partitioning.
    I let the installer create the normal partitioning, and edited it to make partitions for the following...
    boot, swap, var, var/log/audit, tmp, home, and root.

  • It looks like the schema is overlapping the two var logical volumes for some reason. I manually fixed it and attached it for you, but it looks like there is a bigger issue here that I'll need to look into, not sure if you'll run into any other problems.

  • This seems to have fixed it. Going to push forward and see if anything else breaks. I'll have to recapture this again in the not to distant future, any suggestion on how I could prevent it, or fix it on my own?

  • I haven't looked at the issue yet, but I'm guessing I'm doing some type of grep on the logical volumes when creating the schema, in your case you have two /var and somehow the grep is matching both and putting in values for all matching instead just a single one. I'll need to look into it, if you want you could poke around the lie_upload script.

  • Wanted to circle back and let you know how much I appreciate how quickly you responded.

  • Object reference not set to an instance of an object. exactly what it says, you are trying to use a null object as if it was a properly referenced object. Most of the time, when you try to assing value into object, and if the value is null, then this kind of exception occur. [url=]NullReferenceException[/url] indicates that you are trying to access member fields, or function types, on an object reference that points to null. That means the reference to an Object which is not initialized.

  • Hello again - I captured another image with custom partitioning like before and I am getting the same error. Can you take a look? Schema attached.

  • I managed to compare it to the last time you fixed it, and was able to at least get the error to go away. Going to test deploying it and see what happens.