Lie_global_functions and lie_deploy show errors

  • Using Clonedeploy on WIndows, cloning a Centos 7.5 box with 8 partitions (xfs) on a 1T hard disk.
    When uploading the image we get script error, repeated for each partition:
    /bin/lie_global_functions: line 17 <3604> Terminated
    lie_reporter 63 partclone (wd: /)
    However, the process seems to complete successfully. On deployment of that image, we get a different error:
    /bin/lie_deploy: line 164: [: : integer expression expected
    ERR signature for logical partition invalid: read 0x3DCC , but should be 0xAA55..., and it bombs out at that point.
    Tried the 'dynamic' options in settings, no difference. Isn't AA55 a 'magic' MBR number? BTW, when rebuilt the image to 7 partitions, the deployment fails on it too (i.e. always on the last partition).

  • /bin/lie_global_functions: line 17 <3604> Terminated is normal, a background process is started and terminated for each partition.

    Can you attach the upload and deploy logs?

  • Thanks, that makes sense...
    One of the later set of logs attached.

  • Did you try setting Force Dynamic Partition For Exact Hdd Match

  • Yes, we did. Had several iterations since, but will try again right now and let you know!

  • Tried again, on a new build, with the Create Partition method set to Dynamic, and Force Dynamic Partition for Exact Disk Match ticked. Same error.

  • Can you post that deploy log?

  • Also can you try this on the machine you are trying to deploy to.
    Boot to the client console and run
    [code]sgdisk -Z /dev/sda[/code]

    Then try to deploy it again.

  • Did that, still no luck.
    Without the Exact Disk Match setting it threw the exact error as before (ERR signature...).
    With the Exact Disk Match set, it now shows "Couldn't dynamically create partition layout.".

  • At this point I don't know what's happening. I'll need to try and replicate the issue. Do you know if a stock CentOS 7.5 install works properly?

  • Yes, the download I used was from a warwick (UK) mirror only 3 days ago, and it installs OK, no problems. Thank you very much for your help!

  • PS. I installed "Server with GUI" (selected in the pre-installation screen).

  • A bit more feedback. Got an image that does deploy. The main change was to modify the partitions manually, and make the last one to be 1 physical sector less than the disk boundary shown by partition tools. I also made it ext4 (rather than xfs), but I suspect the fs type is not relevant.

  • Thanks for the update, I'll look into it.