Windows 10 on HPZ4



  • Hello,

    We have some isseus with Deploying Windows 10 on a HP Z4 Workstation with a M.2 SSD. We can make a Image without any problems but when we want to Deploy we get a few errors in the beginning. Finnaly Windows 10 will not start en comes with a bleu screen. The error we see in the beggining is MBR too Big then he goes futher and Deploy the Image on the system. When he is finisht and Windows 10 has to start then the bleu screen appears.



  • Could ther be a problem with the new Windows 10 release? On the release 1709 we never had this problem, now we have Windows 10 release 1803



  • I have to manage to do a recovery on Windows 10 and see that the M.2 disk is UNKNOW. So CloneDeploy put the Image on the second HD i think. So the problem looks issue with M.2 HD. Please help!



  • Have you updated to 1.3.5?
    Can you attach your upload and deploy logs?



  • Hello,

    Here the LOGS. I have version 1.3.5



  • Hello,

    Here the LOGS. I have version 1.3.5



  • Your deploy logs look like two different images, one is efi and one is bios. Are you deploying to the same type of machine with efi or bios that matches the image?



  • On the computer we make legacy enable. The computer we make the image and take a same computer to deploy it.



  • Correct the logs are different but from the same computer



  • I think CloneDeploy has a problem with the used 256 M.2 SSD disk. If i make an image off a HP Z440 workstation with one SATA disk there is no problem distributing it on the same system but here the bios has a previous version. Maybe i need to change some bios settings, i dont know.



  • Hello,
    I tried a little futher and i think the M.2 disk is not a problem. The problem seems to be with the MBR or GPT setting. I made a new UPLOAD from a macine with MBR partition and a working Windows 10. Now i tried to put that image on the same system with the same 4tb disk. It seems that CloneDeploy can not repair a header or something because that is the message i get. I send the new LOG files so maybe you can see what is wrong.



  • Log files



  • This is an EFI image as seen by the partition layout
    [code]Device Start End Sectors Size Type
    /dev/sda1 2048 1023999 1021952 499M Windows recovery environment
    /dev/sda2 1024000 1056767 32768 16M Microsoft reserved
    /dev/sda3 4295989248 4296194047 204800 100M EFI System
    /dev/sda4 4296194048 7814035455 3517841408 1.7T Microsoft basic data[/code]

    You need to upload from an efi boot option. You can see from the log that you did not.
    [code]Checking if NVRAM needs updated
    mount: mounting none on /sys/firmware/efi/efivars failed: No such file or directory

    Existing NVRAM
    EFI variables are not supported on this system.

    EFI Variables Are Not Available[/code]



  • Hello, thanks for the reply. Yes it is indeed a EFI. I use now CloneDeploy Proxy DHCP en it is working fine because this is working with EFI. Is there also a possibility that we not use EFI? and use our own Proxy?