Upgrade broke computer naming

  • Hello,

    I'm hopig I can get some help. I recently upgraded our CloneDeploy server from 1.2.1 to 1.3.0 (then patched to 1.3.5). This worked normally, but one thing that seems to have changed is that we no longer get a prompt for the computer name when deploying.

    Some background:
    I've been using the older 1.2.1 setup from the previous employee managing the CD server. It's a very basic setup as far as I can see. We upload a general image with some software preinstalled an an admin account configured the way we like it. We don't sysprep at all before uploading. When we go to deploy to another system we get prompted to type in the new computer name. This step saves us doing it after the deployment (as well as a subsequent reboot).

    So, the issue is that now, while everything works as it did otherwise, we do not get that prompt for the computer name after selecting an image to deploy from the list. I don't know if they had something special set up before that the upgrade knocked out, but any help you can give would be great.

    To summarize:
    We used to get: Boot to PXE > On Demand > Deploy > Select Image > Prompt for computer name > Creating Active Task... > Computer Imaged
    After upgrading and following all the steps therein we get: Boot to PXE > On Demand > Deploy > Select Image > Creating Active Task... > Computer Imaged (Name Not Changed)

    Used exclusively for Windows 10 images and, until the upgrade, never had a problem.

  • can you post a screenshot of your admin settings->security page?

  • Here is the screenshot. I know that the computer registration is not on, but we don't want or need these computers registered in the clonedeploy database. Also, the step I'm talking about always came after the On-Demand step when selecting an image and it seems registration happens way before that anyway. If the registration is required for renaming the computer in the new version then we might have to go ahead and do that, but we were hoping to get it working as we had it before, just on the newer version/kernel.

  • Registration needs to be enabled to get the name prompt.

  • Okay, so that works just fine, but now if I go to re-image that same system it never asks for the name again since it's already registered. The old version never did this. It just asked every time no matter what, right before deploying. Is there any way possible to either restore this behavior, or replicate it?

    There are a lot of cases where we see the same system and need to give it a different name (as it gets re-purposed). If I rely on the registration, and then have to go in there to change the name when necessary, we're going to have a list of thousands of machines before long that

  • I always resuse same names I just delete from AD first?

    My names are based on physical location though.

  • @TB_Admin you are correct. Someone else has requested this functionality also. I have already implemented in the next version, to keep registration disabled and still prompt for a name. It should be available in the next month or so.