Black screen on MateBook X Pro

  • I'm trying to image a Huawei MateBook X Pro. I get the menu and when I select 'Clone Deploy', the screen goes black (I still see activity on the usb boot device). I tried option suggested in the 'HP usb boot hangs' conversation. I've also tried the different kernels available on my CloneDeploy 1.3.5 server.

    I'm trying to put in the latest kernel 4.18.3 to test, but it seems the link [url=][/url] can't be reach.

    Any assistance is appreciated.

  • did you create the usb with rufus

  • I tried creating as iso and used rufus to make usb bootable. I also tried creating with usb build type and ran makeboot with same results.

  • I'm guessing this system is EFI, is secure boot off?

    Can you try adding nomodeset to the grub options?

  • The bios does have a secure boot which was disabled; it doesn't explicitly have an enable legacy option.
    nomodeset-- I've tried that with from the 'HP Boot hangs': select clonedeploy and press e find consoleblank=0 and add nomodeset leaving a space between them press f10 to boot
    For me, F10 does not does not work- 'Ctrl-x' performs reboot but does not resolve issue. Is there another way to implement nomodeset? -- Configure boot menu?
    How about the 64config.txt file to try out the 4.18.3 kernel?
    Thanks for the response and suggestions.

  • You can edit the grub.cfg file directly on the usb drive and add nomodeset. I have also attached the kernel configs.

  • Appreciate the assistance, however I'm unable to get this to boot to image. Edited the grub.cfg but same results.

    I tried following your directions to create custom kernel but unable to get that as well. I tried Ubuntu 12.04 on 2 different kernel versions but come across same issue:

    built-in.a: member arch/x86/kernel/head_64.o in archive is not an object
    make: *** [vmlinux] Error 1

    built-in.a: member arch/x86/kernel/head_64.o in archive is not an object
    make: *** [vmlinux] Error 1

  • I have compiled the latest kernel.

  • Thanks so much. Greatly appreciate the help. This however is still not working. I will need to investigate it more. We will not be ordering these laptops until we have an imaging solution for it.

  • Have you tried the WinPE imaging environment?

  • No, I will test that and let you know. Thank you.

  • Thank you so much, WinPE works!