Multicast Problems

  • Hi,

    Last issue to resolve before I can migrate from CrucibleWDS to CloneDeploy. Website has been offline a good few days so was worried.

    When using Unicast I get 8GB per minute, when trying to Multicast I get 20kb/per minute (about 1000 + hours to complete) or the multicast doesn't even start and all systems hang awaiting the "start" signal or something.

    I have tried without a blocksize and tried with --blocksize 600.

    Same switches / network / systems I use for the room of 16 devices as Crucible but the CD Server is a much higher spec system.

    I have only removed the energy saving features on the NIC and matched any to the old system but there could still be outstanding tweaks on this too.

    I've tried different PXE Kernals as well and didn't notice a difference.

    Where could I be going wrong?

    • I believe although server is at 1GB at the nic that switch ports are hard-set to 100mb for the 16 devices, that said CrucibleWDS is using exact same ports but has a slower NIC at server end and I get about 700MB per minute Multicast and about 1.2GB per minute Unicast. (on the oldest and slowest devices, same used for this testing)

  • CrucibleWDS running Windows 7
    CloneDeploy running Server 2016

  • Multicast can be tricky. Same process is still from Crucible. I suspect the nic. Try setting the nic to 100mb in device manager instead of auto. Then try again, with and without blocksize 700.

  • NIC has been hard set to 1GB and 100MB full duplex before in testing and I know on 1 occasion imaging worked but I had left site for lunch so missed it.

    So 1 setting made it work in realistic time scales but I cant say what it was or how fast (I tried all sorts)

    So next steps I will try what you suggested above.

    100MB full duplex @ NIC Level
    Blocksize 700

    • no other changes

    will test tomorrow and report back, thank you.

  • Also - When testing 1 Device Multicast it didn't suffer issue and got mega speeds but potentially it just acts as a Unicast when doing a Single Device Group?

  • Correct.

  • Hi,

    I have made changes and testing UNICAST (as need to amend an image) and speed has dropped from about 6-8GB to 455mb per minute.

    100mb @ NIC and Blocksize 700 (Multicast settings).

  • I've had switch ports uprated to 1000TX full duplex

    Changed CrucibleWDS to 1GB fullduplex and saw an instant Unicast speed upgrade to 2 GB/PM (nicast speed 2/3 faster) - Multicast untested. but this system works fine anyway.

    Will try same for CloneDeploy with the above 700 blocksize but change NIC to 1GB to match and see how it fairs.

  • Yes, change the nic to 100mb will slow down unicast, I just wanted to test the multicast to see if it's better that way. If so, you can use 2 nics, one for unicast and one for multicast.

  • Now Testing Multicast and speed is 1.57mb per minute.

    • Same Switches and Devices/ Cabling as Crucible.

    --Blocksize is set higher than 700, it's set to 1456 though same as Crucible.

    Unsure why system of higher spec performs worse, never been able to make jump to CD on various hardware I've tested.

    PC/Server only has a single NIC but Crucible was same.