SSD to HDD deployment failure

  • Hello,

    I've just managed to deploy the first machine of a 12 PCs classroom with the image from the first PC. It all went fine and it's up and running, just had to put it out and in of the AD to get the domain login working again. The thing is that both machines have exactly the same hardware. The second one I just tried, like the remaining PCs, differs in the hard drive, being an HDD instead of SSD. The deployment first failed and then restarted automatically but once I logged on to Windows I realised the deployment was done on the Data (D:) disk and not the system disk and I ended up with two OS installed. I managed to deploy the first PC using the profile on pic 1 and 2. What do I need to change in the configuration to match the device names with the remaining computers?


  • So these machines have two regular HDD's in them? I'm guessing it's /dev/sda and /dev/sdb. Can you post the deploy log to verify?

  • Thank you for the fast reply. I will get the log tomorrow when I get to work.
    The room configuration is as follows:

    15 PCs running Win10 Pro.

    -13 with 1 500GB HDD for OS and 2 1TB striped HDD for data.
    -2 with 1 250GB SSD for OS and 2 1TB striped HDD for data.

    I imaged one of the SSD computers and deployed onto the other which went fine.
    I then tried deploying the same image on one of the HDD computers and it seemed to be going well but at some point after the last of the 4 partitions was copied by partclone, there was an error and the process repeated itself, this time, it seems, on the data volume. Tomorrow I'll get the log and post it here.

    Also, on another subject, I did not sysprep the first image before upload and I was surprised to see that even the machine SID is different, and so was the computer name. Windows didn't ask for activation key and even Adobe Creative Cloud didn't seem to bother.. is this normal? should I be syspreping anyway?


  • Btw, where can I find the deploy logs?

  • If computer is registered:

    If not registered:
    admin settings->logs->on demand

  • There are some advances, meanwhile I managed to deploy on the correct disk. I realised I had to specify on the image profile deploy options the actual destination, dev/sda in this case. But now something else is wrong because I'm getting the "reboot and select proper boot device..." message.

    I'm getting a server error trying to attach the log and pictures. (Increase post_max_size) so I'll paste here the options as I have them:

    Change Computer Name (checked)
    Don't Expand Volumes
    Update BCD
    Randomize GUIDs
    Fix Boot Sector (checked)
    Don't Update NVRAM
    Create Partitions Method ( I tried with both 'Dynamic' and 'Use original MBR/GPT' )
    Modify The Image Schema (checked)

    I see that in 'Export Schema' there is nothing under boot flag for /dev/nvme0n1 (the disk where OS is installed on the original PC). Is this ok?

  • post size should be fixed. The boot flag is normal since it's an EFI system there is no boot flag

  • Hello, here's the log from the last attempt to deploy the OS image from the SSD on the HDD PC.
    I used the options attached. Upon specifying the disk to where I wanted the SSD image to deploy it seems it deployed to the correct disk, however it became non bootable. Also, i think I might be missing something here as i suppose I shouldn't be required to specify since I might be deploying the image to 10 computers and don't really be able to know the name or order of the harddisks installed on the machines and have to create a profile for each one individually, or is that the case?

  • Can you try checking the box: force dynamic partitions for exact hd match

    and deploy again?