Kernel NMI Errors



  • Hi, so I'm attempting to image a set of four Toshiba Satellite C655D-S5300 laptops. I've tried every kernel provided by CloneDeploy and on SourceForge, and I keep getting an extremely odd error on every one of them. Some research tells me it's a kernel-related issue, but I'm curious: Should I have to keep trying kernels other than these provided ones?

    The error I receive is usually one or two copies of these lines:

    "Uhhuh. NMI received for unknown reason 3c on CPU 0.
    Do you have a strange power saving mode enabled?
    Dazed and confused, but trying to continue"

    After those lines, the machine just shuts off.

    Usually this occurs when CloneDeploy starts writing MBR / GPT Tables, but it's occurred both before and after.
    Due to my small amount of laptops at this point, I could just do clean USB installs, however I might get up to 30 more soon, so I'd prefer not to do that.

    Thanks for any help,
    Eric



  • Are there any power saving features in the bios, can you try different options if so?



  • You could also try passing in the argument
    [code]acpi=off[/code]



  • So I checked that, and there's not really any except maybe "Dynamic CPU frequency Mode" which has two options, "Always low" and "Dynamic Switch" . Neither of those made too much of a difference, but I'll try the acpi=off thing, will report back.



  • Alright, so tried ACPI=off and still received errors and this time I got a screen almost like multicolor TV static after the errors were thrown...though I think I've gotten that before I tried ACPI off



  • Just want to verify the acpi=off was passed in properly. Where did you put it in at?



  • Tried placing it in the boot menu file editor directly and in the image profile PxE section....I probably did it wrong with my luck...



  • Seems like should work, that should cover both an on demand pxe boot or a task started from the web. Have you tried kernel 4.18.5?
    http://files.clonedeploy.org/kernels/4.18.5/4.18.5x64



  • Just did, and same thing 😞 Thank you for trying to help, I'm not sure this one is meant to be though xD



  • Yea, some computers just don't play nice. The only other last resort is to use the WinPE environment, assuming you are cloning Windows.



  • Cloning Linux, so yeah unfortunately so. Have a nice day, thank you again!