After merging 1.3.5 patch, I have the following error

  • I installed a new VM with ubuntu and clonedeploy 1.3.0

    Everything seems to work up to this point.

    But after merging 1.3.5 I have this error after selecting any pxe boot option.


    Its probably permissions. How's the proper way to merge the files?

  • Hi guys. It seems support has stopped for this project.

    Anyone knows how to properly merge the patch 1.3.5 into 1.3.0 in ubuntu?

    After patching by simply copying the new folders into place, something fails when trying to use the program, as you can see above.

  • Support hasn't stopped. Just getting harder to find the time. It seems like your initrd file is corrupted, have tried reapplying the patch?, or just the initrd file?

  • Thanks for the reply. I understand.

    I actually reinstalled the OS and did everything again. The same happens when copying the patch folders into the original locations.

    Am I doing this right?

    $ sudo su
    $ service apache stop
    $ cp -r /1.3.5/frontend/* /var/www/html/clonedeploy/frontend/
    $ cp -r /1.3.5/application/* /var/www/html/clonedeploy/api/
    $ cp -r /1.3.5/tftpboot/* /tftpboot/

    I noticed permissions for the replaced files are all changed compared to the original files.

  • That looks right to me. This is a strange error, not one that's ever been reported. It seems like the client is loading initrd properly, so I don't think it's a permission issue. You could try running this:
    chown -R www-data:www-data /tftpboot /var/www/html/clonedeploy

    Just to clarify, if you don't update to 1.3.5, you can pxe boot on that same computer with no issue?

  • If I dont update from 1.3.0 to 1.3.5, everything works correctly. It is indeed the patch.

    I ran that chown -R before I started this topic. It didn't work either.

    Maybe I will try to patch to version 1.3.1 or 1.3.2 and see if it happens.

    I can send you the virtual machine with the error happening. Its only 2GB

  • Can you calc the sha for initrd.xz?

    [code]sha256sum /tftpboot/images/initrd.xz[/code]

  • 987df814b0ae35ae9ebe396dad825fbb7d9d54c66a97d61b42c1b56b04c8b233 /tftpboot/images/initrd.xz

  • After patching to 1.3.5? That's not a match. Should be.


  • so what happened is that last week your website was down, so I searched a mirror to download patch 1.3.5 from here: 1.3.0/Patches/

    I re-downloaded the patch from your website now, and the sha is now:

    I booted into PXE correctly now with patch 1.3.5!

    pxe kernel is 4.13. Is this correct? I had in my mind 1.3.5 was kernel 4.16

  • 1.3.5 comes with 4.16.1, but doesn't change any of the assigned kernels. You just need to update it from the boot menu admin section.

  • Correct once again!

    I have to convince my bosses to donate. Keep up the good work!

  • Np, thanks.