MBR Image, Deploy to GPT System



  • Hello,

    My reference image is created in VMWare and uses MBR partitioning. I am trying to deploy to a newer Dell PC, and the BIOS requires UEFI. So I need to deploy my image with a GPT partitioning scheme.

    How would I do this? I thought the dynamic partitioning setting changed the boot partitioning, but that doesn't seem to be the case. After what looks like a successful deploy, there are no bookable devices found. Accorind to the log, it's applying MBR partitioning.



  • I tried using a gparted live disk to run gdisk on the hard drive - it complained about overlapping sectors. I fixed that by shrinking the partition a few MB, then the gdisk commands succeeded. It was still unable to boot in UEFI - no bootable devices found.



  • In your deploy schema your create partitions method needs to be set to standard, this is the only way to do mbr to gpt and even then it's limited. When using standard it will detect if you booted in efi or bios mode and set the partitions up the proper way, you can also force efi or bios



  • Okay, I changed it to standard partitioning, modified the schema, deselected the boot partition. When I tried to save without deselecting the boot partition, I got an error saying "only one partition can be active with the OS".

    Going to run a test now - will report back.



  • Hmm, no luck. Entirely possible I didn't set it up right. Here's the deploy log.



  • Didn't realize this was Linux, efi to bios and vice versa only works with Windows



  • Bummer, sorry for not specifying. Have any advice? Don't really want to remake the reference image.