[SOLVED] CDProxy iPXE EFI wrong ip during tftp transfer

  • My setup:
    Ubuntu box with CloneDeploy setup and running with tftpd-hpa configured.

    All is well for when I use my DHCP server for opts. 66 and 67 and choose one PXE using CloneDeploys web interface. Both CSM and UEFI boots work when I do this.

    With the cdproxy I've tried both Windows and Linux environments for cdproxy and both exhibit the same behaviour.

    The Issue:
    iPXE grabs the pxeboot.0 file from my server ( No problem.
    Then a TFTP transfer gets going but it is requested from a different IP address (, but has the correct directory structure (proxy/efi64/pxelinux.cfg/default.ipxe)

    This does not happen for BIOS boots, just for iPXE. cdproxy/tftp serves just fine when it is a request from a BIOS machine.
    I tried GRUB but I only end up getting a GRUB commandline with cdproxy or a terminal cursor by using my DHCP server

    Options 66 and 67 are commented out in the DHCP server when the issues occurs.

    Attached are the cdproxy and dhcpd configs

  • I don't see anything in your config that would do this. What is

  • is my DHCP server.

  • Something going on with your dhcp server, I think. Typically the next-server is left blank when it's not defined, but it seems like your dhcp server is setting it to itself, which is causing ipxe to read that value before the value set in the proxy. I've never used isc dhcp so I cannot say for certain, but I have seen other DHCP servers that incorrectly set this value also.

    It is mentioned in the documenation

    CloneDeploy Proxy will not override options that are already set by your DHCP server. If you have already set option 60, 66 or 67, you must remove them before it will work. [b]In addition to this, some DHCP servers incorrectly set the next-server to be themselves even if you have not set it. These will not work because options cannot be overridden[/b].[/quote]

  • Setting next server in my dhcp config file solved it. Many thanks!