Adding a computer from Client Boot Method [Solved]



  • Hello

    I'm trying to create my first image using the online documentation but I must be doing something wrong. This is what I have done so far:

    • My created image definition have these settings:
    • lmage name: test
    • Image env: winpe
    • Classification: none
    • Enabled: yes
    • Protected: no
    • Visible on demand: yes

    The selected client boot method is PXE Booting. Client (a DELL optiplex 790 PC) has "LAN with PXE boot option" enabled. When I start the machine, I get this:

    PXE-E52: proxyDHCP offers were received. No DHCP offers were received.
    PXE-M0F: Exiting Intel Boot Agent. No boot device found.

    At this point shouldn't the machine be able to see my CloneDeploy 1.3 installation so that I can add the machine to CloneDeploy?

    DHCP Server and client are on the same network.

    Thank you



  • First of all, you probably want your image environment set to Linux. That is the recommended option, and only use winpe if compatibility issues arise. As for the pxe, did you set the boot options for your dhcp scope?



  • @clonedeploy_admin

    Hello

    Sorry for my very late reply but I made a small progress. I have set my image environment to "Linux" and "boot options" have been set. I asked for these lines below to be added in dhcpd.conf

    option bootfile-name "pxelinux.0";
    next-server "192.168.5.14";
    

    The reason I was seeing the 2 lines shown in my first post was because only registered MAC addresses are allowed to DHCP. My client test machine was not registered to access our network. This is now changed and it does get an IP address, however the boot process stops there. At the moment when the client PC boots up I see this:

    Client MAC address 78:2B:34:B7:03:F7    GUID: 34343D3D 3500 1059 8043
    Client IP: 192.168.6.35    MASK: 255.255.254.0    DHCP IP: 192.64.34.18
    GATEWAY IP: 192.168.6.250
    TFTP.
    PXE-M0F: Exiting Intel Boot Agent
    No Boot device found. Press any key to reboot.
    

    Is there something else I need to check so I can make this work? Client machine has IP 192.168.6.35 and server has 192.168.5.14. They are on the same VLAN but different subnet. Do you think this causes the problem?

    Thank you



  • Your bootfile name is incorrect.

    option bootfile-name "pxelinux.0";
    

    should be

    option bootfile-name "pxeboot.0";
    


  • @clonedeploy_admin

    Thank you for your time and support. 👍
    I can see "clonedeploy" boot menu now.