Copy folder and run exe on post script



  • Hi,
    I only discovered CloneDeploy yesterday and so far it seems great. I have an image which restores perfectly every time.

    I'm having an issue understanding how to copy a folder and then run an exe. I've created the folder and two files within but each time the log says the folder does not exist. I have a folder called Software, and a subfolder called Installs. This subfolder is what I want to copy to C:\Installs on the imaged machines.

    The Windows machine image has a single C drive.

    Log:

    ** Processing File Copy **
     
    { "DestinationFolder": "Installs", "DestinationPartition": "1", "FolderCopyType": "Folder", "SourcePath": "Software/Installs" }
     
    ** Updating BCD **
    mount: mounting none on /sys/firmware/efi/efivars failed: No such file or directory
    EFI variables are not supported on this system.
    

    Then I wanted to run a script to run post-deploy > C:\Installs\MyFile.exe but this obviously does not run. But is my script correct>

    #!/bin/bash
    /mnt/c/Installs/MyFile.exe
    

    Many thanks in advance



  • You destination folder should just be set to /
    This would then copy the Installs folder to c:\

    It's currently try to copy installs to c:\installs\installs, but can't because c:\installs doesn't exist.

    Also be sure that partition 1 is the correct partition, and remember all folders are case sensitive.

    As for the scripts, they run during the image process, so what you are trying to do won't work. If you are using sysprep you could use that to run a process after imaging is complete. We also have another product, Theopenem that was designed to run these type of tasks after imaging is complete.



  • Thanks for the pointer, that sorted it!

    I'll take a look at the other product, thanks for the quick reply.