Unable to create deployable images



  • Hi Guys,

    Just starting using CloneDeploy, loving it so far however I've run into an issue when uploading an image of a specific model of Ubuntu machine.

    I'm using a USB to boot into CloneDeploy, I'm am able to start an on-demand task to upload/image the machine but I get a list of errors when the Image Schema is being created:
    error on upload.jpg

    I've tried to deploy the image but I get an error stating:

    "Unknown Error Occurred While Determining Minimum HD Size Required"
    

    I'm also unable to view the Schema in the webpanel.
    webpanel error.png

    Hoping anyone is able to shine some light on this, is there something I'm missing when uploading the image?



  • Those mmc drives can be problematic, it needs a patched kernel. With the release of CloneDeploy 1.4.0, the older patched kernels don't work. I'll need to patch one of the new kernels and get back to you. Can you attach the upload log?



  • Might be a newbie question, but how do I get the upload log?



  • In webUI.
    If registered computer, computers->search->view->logs
    if not registered, admin settings->logs->on demand



  • Fab, it's attached.

    STERITEST-1-onddeploy.txt
    0c9a422f31ea-ondupload.txt

    edit: uploaded deploy log not upload log.



  • Instead of modifying the kernel, I modified the scripts to try and exclude the unneeded partitions for these mmc drives. You can download the changed scripts from http://files.clonedeploy.org/mmc_fix.zip

    Extract the files to /var/www/html/clonedeploy/api/private/client_scripts and overwrite the existing files.

    These scripts will only work for 1.4.0. It looks like you are using an older version, you will need to update prior to trying these. I'm not sure if this will definitely fix the issue, but it should at least get us one step closer.



  • Seems to have done the trick,

    I do still the errors during the schema creation saying:

    Error: /dev/mmcblk0... unrecognised disk label
    

    is this something to be worried about?



  • That's normal, anything with an unknown disk label is just ignored. I've really only ever seen that with the mmc drives.