USB Boot not finding CloneDeploy Server



  • Hello,

    I'm pretty new to CloneDeploy so maybe i missed something in the documentation, if so just point me there. I am trying to capture my first image (Windows 10) of a Dell Optiplex 3060.

    Current setup:
    CloneDeploy server on a Dell Optiplex 3040
    No DHCP on the network, everything is statically assigned
    Under Images i created a Image Definition (everything left default)
    Client Imaging Environment - Linux, Image Type: Block, etc...
    Under Boot Menu i did USB build type, I have tried each Kernel 4.18 through 5.0 with Kernel Arguments:
    [code]cd_net_ip=x.x.x.x cd_net_netmask=255.255.255.0 cd_net_gateway=x.x.x.x[/code]
    with the x's being the ip address of the server and default gateway.

    When i boot off the usb (on the Opitplex 3060) i choose CloneDeploy, then it says
    Starting Network On Interface eth0
    ifup: interface lo already configured
    ifdown: interface eth0 not configured

    then it switches to:
    Could Not Contact CloneDeploy Server. Possible Reasons:
    The CloneDeploy Web Service is not Function.
    Try Entering http://"servername"/clonedeploy/api/ClientImaging/Test (when i do i get a webpage that just says true)
    A Driver Could Not Be Found For This NIC.
    The Computer Did Not Receive An Ip Address.
    Press Enter to Continue.

    When i hit enter it shuts down.

    I have also tried the same process but manually adding the computer with MAC address and starting the capture computer task.

    Is there a way for me to tell CloneDeploy what driver to use?

    Any help is greatly appreciated!



  • Do you have the server ip field set to an ip address or fqdn. If it's not ip, the name won't resolve because the nameserver isn't being set without dhcp.



  • Thank you for the quick reply.

    Under Admin > Server Settings > Server i have the Server IP/FQDN field set to the ip address of the machine.