Not detecting NVMe drive

  • Just bought some new Dells that come with nvme drives and when I launch the pxe boot to create a image, it says it can't find any drives.

  • Check the bios if the hd mode is set to raid, change it to something else

  • That worked! Thanks! Now just to figure out why it is stuck on the Creating image Schema step.

  • Hi,

    I have exactly the same problem. Until now, we were using HP and Lenovo computers and everything was working without any problem but since we moved to Dell, CloneDeploy isn't working anymore. I already tried with the secure boot disable, Sata operation set on disabled and also on AHCI instead of RAID. And of course, all my test have been done in Legacy instead of UEFI. To be sure, I also tried starting the deployment from a USB Generator. I also tried with different kernel (4.20.10x64 and 5.0.rc7x64)

    At the moment, deployment process looks great but once it's done and the computer is rebooting, I get the following message:
    No bootable devices found.
    Press F1 key to retry boot.
    Press F2 key for setup utility
    Press F5 key to run onboard diagnostics.

    Does anyone has an idea to fix this problem?

    The Dell laptop I used for those test is a Latitude 7490 with a SSD M.2 PCIe NVMe.

    Thanks for your help

  • Is the actual image BIOS or EFI based?

  • I would say it's an EFI. To prepare this image, I made a Win10 VM on VirtualBox. Then I uploaded this VM on the CloneDeploy server via the Upload option from CloneDeploy, I mean by booting on the Lan. As there is no BIOS option on a VM, it should be EFI.

  • I made some additional tests and found a way to fix the problem. It's a kind of bypass but it works. So finally, instead of using the VM I already have, I uploaded an image from a Dell laptop with default configuration (I did a recovery). After that, I deployed this image on the same Dell laptop and it worked. So I will customize this image instead of the others I already have.

    So according to me, the problem is related to a driver which is missing in the image I used, probably for the NVMe.

    Thanks for the support!

  • I believe your original image was built using the BIOS(Legacy) method even though it is a VM. I have had the same issue only mine was I built an UEFI image using Hyper-V, and tried to deploy to a BIOS based machine. It is also important that you boot the machine to CD using the method the machine will normally boot afterwards.

    Just for giggles, you should try your original image, but in the CD interface change the "create partitions method to standard in admin settings > Image profile templates then deploy again and see if CD doesn't fix the partition layout automatically for you

  • Hi ace256,

    This was exactly the issue I had. I did some test last friday and yesterday and found the problem just before I got your answer. As this can help somebody else, here is what I did:

    • Download of the Dell ISO (Win 10 Pro) using Dell OS Recovery Tool.
    • Enable the EFI in VirtualBox and creation of a new VM.
    • Upload of this VM on the CloneDeploy server. I used the ISO Generator in order to boot on the LAN.
    • Deploy of this image on the Dell laptop I have. I used the USB Generator in order to boot on the LAN.

    And guess what!? Success. Thanks for your help.

  • Awesome, glad you got it working.

    Just to further clarify, with your new image if you make the modifications I was talking about you can deploy that EFI based image to both style (UEFI and BIOS/Legacy) machines, that is one of the fantastic things about CD and has saved us a ton of time.

  • Yes I will try this option as well but at the moment, I'm so happy that everything works so I don't want to play to much with this tool.

    Thanks again for your support.