Server Error in '/clonedeploy' Application.



  • Hi Team,

    I'm getting this error below , on the first intial install. I'm not sure exactly why, I even attempted to do a reinstall again and same error. I refresh mysql and iis

    [NullReferenceException: Object reference not set to an instance of an object.]
    CloneDeploy_ApiCalls.UserAPI.Put(Int32 id, CloneDeployUserEntity tObject) +96
    CloneDeploy_Web.views.login.views_login_firstrun.btnSubmit_OnClick(Object sender, EventArgs e) +179
    System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e) +109
    System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +101
    System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
    System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
    System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +167
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3464



  • This error has also been posted by 2 or 3 other people, right now I haven't been able to determine what is causing this and why it's only happening for a small number of people. What OS are you using?



  • I've been having the same issue with Server 2016 Standard (64 Bit), v1607, build 14393.3056



  • The error in 1.3.x is above, and in 1.4.0 the error is now:

    [NullReferenceException: Object reference not set to an instance of an object.]
       CloneDeploy_ApiCalls.UserAPI.Put(Int32 id, CloneDeployUserEntity tObject) in C:\Development\clonedeploy\CloneDeploy-ApiCalls\UserAPI.cs:232
       CloneDeploy_Web.views.login.views_login_firstrun.btnSubmit_OnClick(Object sender, EventArgs e) in C:\Development\clonedeploy\CloneDeploy-Web\views\login\firstrun.aspx.cs:20
       System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e) +136
       System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument) +147
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +5027
    
    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.7.3429.0
    


  • This is windows 7 32bit for my error.



  • @clonedeploy_admin Hello. After my solving my previous problem where I couldn't login to the GUI I too now have the same error as described above. As my previous problem had something to do with the IIS I'm guessing now again it could have something to do with that. I will keep searching for an solution but I hope you can help me (and the others) with this same error. Is there an other way (configfile or something like that) where I can save the Server IP? It seems that because I can't save the 'first time' configuration I therefor can't get an server IP. But that's just guessing.



  • I think, after all this trouble i'm having to getting it work, I did everything I could think off, I will look for an alternative program. It is really an bummer, because I have great respect for the creator and used it now for years after I used Norton Ghost. But this specific error isn't solved and I keep getting it so I can't get it to work on my new installed server. Fresh install of the server isn't an option so I don't have an lot of options as I already lost an lot of time to get it work.

    I've multiple times reinstalled after removing with removalsoftware and tried using previous versions but nothing works. Don't know what I can do more and in all the other posts with the same error there isn't any solution described.



  • @GLS54 This was what I could find in the logs: ERROR CloneDeploy_ApiCalls.ApiRequest Response Data Was Null For Resource: api/User/Put/1